summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 05:39:03 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 05:39:03 +0000
commitbfe45dedd09a83e0a06575e434156eabae55e91e (patch)
tree74c8c356c3b9fc949211f4f2c5923e63767e5ecd /sys-power/athcool/athcool-0.3.12.ebuild
parentAdded ~x86-fbsd, bug #358079 (diff)
downloadgentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.tar.gz
gentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.tar.bz2
gentoo-2-bfe45dedd09a83e0a06575e434156eabae55e91e.zip
Version bump. Set RDEPEND.
(Portage version: 2.2.0_alpha41/cvs/Linux i686)
Diffstat (limited to 'sys-power/athcool/athcool-0.3.12.ebuild')
-rw-r--r--sys-power/athcool/athcool-0.3.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-power/athcool/athcool-0.3.12.ebuild b/sys-power/athcool/athcool-0.3.12.ebuild
new file mode 100644
index 000000000000..c8f58f806efe
--- /dev/null
+++ b/sys-power/athcool/athcool-0.3.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.12.ebuild,v 1.1 2011/06/15 05:39:03 jer Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
+HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
+SRC_URI="http://members.jcom.home.ne.jp/jacobi/linux/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.11-build.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ doinitd "${FILESDIR}"/athcool
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Depending on your motherboard and/or hardware components,"
+ ewarn "enabling powersaving mode may cause:"
+ ewarn " * noisy or distorted sound playback"
+ ewarn " * a slowdown in harddisk performance"
+ ewarn " * system locks or unpredictable behavior"
+ ewarn " * file system corruption"
+ ewarn "If you met those problems, you should not use athcool. Please use"
+ ewarn "athcool AT YOUR OWN RISK!"
+}