summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-18 05:49:01 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-18 05:49:01 +0000
commitf1a7f425d66fded5bc317ed209e4a89d4fd30368 (patch)
tree596768962d7a028d5c245d0594790c9b4f55eeb2 /sys-libs
parentVersion bump. Bug #376371 (diff)
downloadgentoo-2-f1a7f425d66fded5bc317ed209e4a89d4fd30368.tar.gz
gentoo-2-f1a7f425d66fded5bc317ed209e4a89d4fd30368.tar.bz2
gentoo-2-f1a7f425d66fded5bc317ed209e4a89d4fd30368.zip
Version bump which includes a fix from upstream for #382005 by Maks Verver.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/ChangeLog8
-rw-r--r--sys-libs/libunwind/files/libunwind-1.0.1-disable-setjmp.patch37
-rw-r--r--sys-libs/libunwind/libunwind-1.0.1.ebuild50
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-libs/libunwind/ChangeLog b/sys-libs/libunwind/ChangeLog
index e04c83468eb8..d881eb345255 100644
--- a/sys-libs/libunwind/ChangeLog
+++ b/sys-libs/libunwind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libunwind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.16 2011/08/28 15:18:02 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/ChangeLog,v 1.17 2011/09/18 05:49:01 vapier Exp $
+
+*libunwind-1.0.1 (18 Sep 2011)
+
+ 18 Sep 2011; Mike Frysinger <vapier@gentoo.org> +libunwind-1.0.1.ebuild,
+ +files/libunwind-1.0.1-disable-setjmp.patch:
+ Version bump which includes a fix from upstream for #382005 by Maks Verver.
28 Aug 2011; Naohiro Aota <naota@gentoo.org> libunwind-1.0.ebuild:
Add QA_DT_NEEDED for x86-fbsd
diff --git a/sys-libs/libunwind/files/libunwind-1.0.1-disable-setjmp.patch b/sys-libs/libunwind/files/libunwind-1.0.1-disable-setjmp.patch
new file mode 100644
index 000000000000..442a5dfd7a37
--- /dev/null
+++ b/sys-libs/libunwind/files/libunwind-1.0.1-disable-setjmp.patch
@@ -0,0 +1,37 @@
+http://cvs.fedoraproject.org/viewvc/rpms/libunwind/devel/libunwind-disable-setjmp.patch?revision=1.1&view=markup
+http://bugs.gentoo.org/299344
+
+At least x86_64 version cannot work, src/setjmp/setjmp.c and
+src/setjmp/sigsetjmp.c are not even compiled, src/x86_64/longjmp.S does not
+match src/setjmp/setjmp.c + include/tdep-x86_64/jmpbuf.h .
+
+--- libunwind-1.0.1/src/Makefile.am
++++ libunwind-1.0.1/src/Makefile.am
+@@ -9,6 +9,3 @@
+ # libunwind-setjmp depends on libunwind-$(arch). Therefore must be added
+ # at the end.
+-if !REMOTE_ONLY
+-lib_LTLIBRARIES += libunwind-setjmp.la
+-endif
+
+ #
+--- libunwind-1.0.1/tests/Makefile.am
++++ libunwind-1.0.1/tests/Makefile.am
+@@ -27,7 +27,7 @@
+ Gia64-test-nat Lia64-test-nat \
+ Gia64-test-rbs Lia64-test-rbs \
+ Gia64-test-readonly Lia64-test-readonly \
+- ia64-test-setjmp ia64-test-sig
++ ia64-test-sig
+ else
+ if ARCH_PPC64
+ if USE_ALTIVEC
+@@ -44,7 +44,7 @@
+ Gtest-dyn1 Ltest-dyn1 \
+ Gtest-trace Ltest-trace \
+ test-async-sig test-flush-cache test-init-remote \
+- test-mem test-setjmp test-ptrace \
++ test-mem test-ptrace \
+ Ltest-nomalloc Ltest-nocalloc rs-race
+ noinst_PROGRAMS_cdep = forker mapper test-ptrace-misc \
+ Gperf-simple Lperf-simple
diff --git a/sys-libs/libunwind/libunwind-1.0.1.ebuild b/sys-libs/libunwind/libunwind-1.0.1.ebuild
new file mode 100644
index 000000000000..893cb7cf1830
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.0.1.ebuild,v 1.1 2011/09/18 05:49:01 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="http://savannah.nongnu.org/projects/libunwind"
+SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="7"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="debug static-libs"
+
+# https://savannah.nongnu.org/bugs/?22368
+# https://bugs.gentoo.org/273372
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+QA_DT_NEEDED_x86_fbsd="usr/lib/libunwind.so.7.0.0"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-disable-setjmp.patch
+ eautoreconf
+}
+
+src_configure() {
+ # do not $(use_enable) because the configure.in is broken and parses
+ # --disable-debug the same as --enable-debug.
+ # https://savannah.nongnu.org/bugs/index.php?34324
+ econf \
+ $(use_enable static-libs static) \
+ $(use debug && echo --enable-debug)
+}
+
+src_test() {
+ # explicitly allow parallel build of tests
+ emake check
+}
+
+src_install() {
+ default
+ # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
+ # shared library, so we keep it in any case
+ use static-libs || rm -f "${ED}"usr/lib*/libunwind{-generic.a,*.la}
+}