summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-01-23 01:39:23 +0000
committerHanno Böck <hanno@gentoo.org>2005-01-23 01:39:23 +0000
commitdc6cc1f58277f32197a9eae99c8752634ca18491 (patch)
treeeb496737767e449e67c56b4cae1e6f612ba5f23f /sys-libs
parentktoblzcheck-1.2 version bump (diff)
downloadgentoo-2-dc6cc1f58277f32197a9eae99c8752634ca18491.tar.gz
gentoo-2-dc6cc1f58277f32197a9eae99c8752634ca18491.tar.bz2
gentoo-2-dc6cc1f58277f32197a9eae99c8752634ca18491.zip
gwenhywfar-1.6.0 version bump.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.6.01
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.6.0.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index bb3f663aafa7..5fb5c4872e0e 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.6 2005/01/14 10:43:40 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.7 2005/01/23 01:39:23 hanno Exp $
+
+*gwenhywfar-1.6.0 (23 Jan 2005)
+
+ 23 Jan 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.6.0.ebuild:
+ Version bump.
*gwenhywfar-1.4.1 (14 Jan 2005)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.6.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.6.0
new file mode 100644
index 000000000000..287b356cddba
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.6.0
@@ -0,0 +1 @@
+MD5 692b3b3d28c70163ea9b2acb1607c156 gwenhywfar-1.6.0.tar.gz 974766
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.6.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.6.0.ebuild
new file mode 100644
index 000000000000..644bf323a03d
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.6.0.ebuild,v 1.1 2005/01/23 01:39:23 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}