summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-08-31 11:47:00 +0000
committerPeter Volkov <pva@gentoo.org>2006-08-31 11:47:00 +0000
commitbf274afb2282942c998b9bd8c8f95c908e111c0d (patch)
tree6366a53b331677646655881fbe2ccd6da567483d /sys-libs
parentstable on amd64 (diff)
downloadgentoo-2-bf274afb2282942c998b9bd8c8f95c908e111c0d.tar.gz
gentoo-2-bf274afb2282942c998b9bd8c8f95c908e111c0d.tar.bz2
gentoo-2-bf274afb2282942c998b9bd8c8f95c908e111c0d.zip
Added fix for new java system. Thank Caster and Tichoj for fix and Jan Callewaert for report of the bug #132690.
(Portage version: 2.1-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog9
-rw-r--r--sys-libs/db/db-3.2.9-r10.ebuild10
-rw-r--r--sys-libs/db/db-3.2.9-r11.ebuild163
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r113
4 files changed, 182 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index ae1b919029b3..73f19093afc7 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.169 2006/08/17 19:45:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.170 2006/08/31 11:47:00 pva Exp $
+
+*db-3.2.9-r11 (31 Aug 2006)
+
+ 31 Aug 2006; Peter Volkov <pva@gentoo.org> db-3.2.9-r10.ebuild,
+ +db-3.2.9-r11.ebuild:
+ Added fix for new java system. Thank Caster and Tichoj for fix and Jan
+ Callewaert for report of the bug #132690.
17 Aug 2006; Jeroen Roovers <jer@gentoo.org> db-4.2.52_p4-r2.ebuild:
Stable for HPPA (bug #142965). There seems no need for HPPA to wait for Java.
diff --git a/sys-libs/db/db-3.2.9-r10.ebuild b/sys-libs/db/db-3.2.9-r10.ebuild
index 54a68e7d4841..653a2e0e6afd 100644
--- a/sys-libs/db/db-3.2.9-r10.ebuild
+++ b/sys-libs/db/db-3.2.9-r10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.24 2006/08/03 23:46:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r10.ebuild,v 1.25 2006/08/31 11:47:00 pva Exp $
-inherit gnuconfig libtool eutils db
+inherit gnuconfig libtool eutils db java-pkg
DESCRIPTION="Berkeley DB for transaction support in MySQL"
HOMEPAGE="http://www.sleepycat.com/"
@@ -26,9 +26,15 @@ DEPEND="${RDEPEND}
# This doesn't build without exceptions
export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+pkg_setup() {
+ use java && java-pkg_pkg_setup
+}
+
src_unpack() {
unpack ${A}
+ use java && export JAVACABS=$(java-config --javac)
+
chmod -R ug+w *
cd ${WORKDIR}/${P}
diff --git a/sys-libs/db/db-3.2.9-r11.ebuild b/sys-libs/db/db-3.2.9-r11.ebuild
new file mode 100644
index 000000000000..605d0c02e9fd
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r11.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r11.ebuild,v 1.1 2006/08/31 11:47:00 pva Exp $
+
+inherit gnuconfig libtool eutils db java-pkg-opt-2
+
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="ftp://ftp.sleepycat.com/releases/${P}.tar.gz"
+
+LICENSE="DB"
+SLOT="3"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc java"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85*
+ sys-devel/libtool
+ sys-devel/m4
+ java? ( >=virtual/jdk-1.4 )"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ use java && export JAVACABS=${JAVAC}
+ use java && export JAVACFLAGS=$(java-pkg_javac-args)
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+ sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-jarlocation.patch
+ epatch ${FILESDIR}/db-3.2.9-java15.patch
+ gnuconfig_update
+}
+
+src_compile() {
+ local conf=
+ local conf_shared=
+ local conf_static=
+
+ conf="${conf}
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+
+ # --enable-rpc DOES NOT BUILD
+ # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
+
+ conf_shared="${conf_shared}
+ `use_enable java`
+ --enable-dynamic"
+
+ # TCL support is also broken
+ # Robin H. Johnson <robbat2@gentoo.org> (18 Oct 2003)
+ # conf_shared="${conf_shared}
+ # `use_enable tcl tcl`
+ # `use_with tcl tcl /usr/$(get_libdir)`"
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} ${conf_static} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} ${conf_shared} \
+ --libdir=/usr/$(get_libdir) \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ libdir=${D}/usr/$(get_libdir) \
+ install || die
+
+ cd ${S}/build-static
+ newlib.a libdb.a libdb-3.2.a || die "failed to package static libraries!"
+ newlib.a libdb_cxx.a libdb_cxx-3.2.a || die "failed to package static libraries!"
+
+ db_src_install_headerslot || die "db_src_install_headerslot failed!"
+
+ # this is now done in the db eclass, function db_fix_so and db_src_install_usrlibcleanup
+ #cd ${D}/usr/lib
+ #ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/$(get_libdir)
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ db_src_install_doc || die "db_src_install_doc failed!"
+
+ db_src_install_usrbinslot || die "db_src_install_usrbinslot failed!"
+
+ db_src_install_usrlibcleanup || die "db_src_install_usrlibcleanup failed!"
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
+
diff --git a/sys-libs/db/files/digest-db-3.2.9-r11 b/sys-libs/db/files/digest-db-3.2.9-r11
new file mode 100644
index 000000000000..94bf83c2428a
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r11
@@ -0,0 +1,3 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
+RMD160 c2c5cdb3ec0e99e5687c0861dfbf76b8878f27cb db-3.2.9.tar.gz 2085238
+SHA256 3eccaec87bca4ca0f5728cf4579650da9d12e331187f1e98321e5c9e9e04b108 db-3.2.9.tar.gz 2085238