summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-06-02 06:02:48 +0000
committerPeter Volkov <pva@gentoo.org>2010-06-02 06:02:48 +0000
commit868902af0a81f17d10f60640be354140d1fe5477 (patch)
treeb6d660e38aafff0715b726524a0defdd83f03dc8 /sys-libs
parentUnmask KDE SC 4.4.4 since we're not adding it to tree yet. (diff)
downloadgentoo-2-868902af0a81f17d10f60640be354140d1fe5477.tar.gz
gentoo-2-868902af0a81f17d10f60640be354140d1fe5477.tar.bz2
gentoo-2-868902af0a81f17d10f60640be354140d1fe5477.zip
Improve python handling and make python bindings USE configurable, fixes bug #301666, thank Oschtan and Alex 12th Voronkov for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libieee1284/ChangeLog10
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/sys-libs/libieee1284/ChangeLog b/sys-libs/libieee1284/ChangeLog
index fd5b041e2875..1513b722fc11 100644
--- a/sys-libs/libieee1284/ChangeLog
+++ b/sys-libs/libieee1284/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libieee1284
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libieee1284/ChangeLog,v 1.22 2009/07/01 10:00:29 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libieee1284/ChangeLog,v 1.23 2010/06/02 06:02:48 pva Exp $
+
+*libieee1284-0.2.11-r1 (02 Jun 2010)
+
+ 02 Jun 2010; Peter Volkov <pva@gentoo.org> +libieee1284-0.2.11-r1.ebuild:
+ Improve python handling and make python bindings USE configurable, fixes
+ bug #301666, thank Oschtan and Alex 12th Voronkov for report.
01 Jul 2009; Alexis Ballier <aballier@gentoo.org>
libieee1284-0.2.11.ebuild:
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild
new file mode 100644
index 000000000000..0722921dfc08
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild,v 1.1 2010/06/02 06:02:48 pva Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+inherit python
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ --disable-dependency-tracking
+}
+
+src_install () {
+ emake DESTDIR="${ED}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README* TODO doc/interface* || die
+}