summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-04-03 00:48:42 +0000
committerJon Portnoy <avenj@gentoo.org>2004-04-03 00:48:42 +0000
commit72738495dbc657df823dfab51554afda0f2a7063 (patch)
tree0ec25c2beda01057de93065d19b5e13829852f66 /sys-libs
parentstable on ppc as required in bug #45159 (Manifest recommit) (diff)
downloadgentoo-2-72738495dbc657df823dfab51554afda0f2a7063.tar.gz
gentoo-2-72738495dbc657df823dfab51554afda0f2a7063.tar.bz2
gentoo-2-72738495dbc657df823dfab51554afda0f2a7063.zip
Revert gpm support
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ChangeLog6
-rw-r--r--sys-libs/ncurses/ncurses-5.4-r1.ebuild14
-rw-r--r--sys-libs/ncurses/ncurses-5.4.ebuild8
3 files changed, 17 insertions, 11 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index a55311853d98..1efe896caad1 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.61 2004/03/30 18:54:38 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.62 2004/04/03 00:48:42 avenj Exp $
+
+ 02 Apr 2004; Jon Portnoy <avenj@gentoo.org> ncurses-5.4.ebuild,
+ ncurses-5.4-r1.ebuild :
+ Revert gpm support entirely due to bootstrap problems.
30 Mar 2004; <rac@gentoo.org> ncurses-5.4-r1.ebuild, ncurses-5.4.ebuild:
Make gpm support not come in if USE=bootstrap, fix bootstrap with USE=gpm set
diff --git a/sys-libs/ncurses/ncurses-5.4-r1.ebuild b/sys-libs/ncurses/ncurses-5.4-r1.ebuild
index 810fa5027e31..8596669dd629 100644
--- a/sys-libs/ncurses/ncurses-5.4-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.4-r1.ebuild,v 1.9 2004/03/30 18:54:38 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.4-r1.ebuild,v 1.10 2004/04/03 00:48:42 avenj Exp $
inherit eutils flag-o-matic 64-bit gnuconfig
filter-flags -fno-exceptions
@@ -12,10 +12,13 @@ SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
LICENSE="MIT"
SLOT="5"
KEYWORDS="x86 ~ppc sparc alpha hppa ~mips amd64 ia64 ppc64 s390"
-IUSE="debug gpm"
+IUSE="debug"
-DEPEND="virtual/glibc
- !bootstrap? ( gpm? ( sys-libs/gpm ) )"
+DEPEND="virtual/glibc"
+# This doesn't fix the problem. bootstrap builds ncurses again with
+# normal USE flags while bootstrap is unset, which apparently causes
+# things to break -- avenj 2 Apr 04
+# !bootstrap? ( gpm? ( sys-libs/gpm ) )"
src_unpack() {
unpack ${A}
@@ -47,7 +50,8 @@ src_compile() {
( use build || use bootstrap ) \
&& myconf="${myconf} --without-cxx --without-cxx-binding --without-ada"
- use gpm && myconf="${myconf} --with-gpm"
+ # see note about DEPEND above -- avenj@gentoo.org 2 Apr 04
+# use gpm && myconf="${myconf} --with-gpm"
# We need the basic terminfo files in /etc, bug #37026. We will
# add '--with-terminfo-dirs' and then populate /etc/terminfo in
diff --git a/sys-libs/ncurses/ncurses-5.4.ebuild b/sys-libs/ncurses/ncurses-5.4.ebuild
index 909e6c9d437b..95311710af28 100644
--- a/sys-libs/ncurses/ncurses-5.4.ebuild
+++ b/sys-libs/ncurses/ncurses-5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.4.ebuild,v 1.8 2004/03/30 18:54:38 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.4.ebuild,v 1.9 2004/04/03 00:48:42 avenj Exp $
inherit eutils flag-o-matic 64-bit gnuconfig
filter-flags -fno-exceptions
@@ -12,10 +12,9 @@ SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
LICENSE="MIT"
SLOT="5"
KEYWORDS="x86 ~ppc ~sparc alpha hppa ~mips amd64 ia64 ppc64 s390"
-IUSE="debug gpm"
+IUSE="debug"
-DEPEND="virtual/glibc
- !bootstrap? ( gpm? ( sys-libs/gpm ) )"
+DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
@@ -46,7 +45,6 @@ src_compile() {
( use build || use bootstrap ) \
&& myconf="${myconf} --without-cxx --without-cxx-binding --without-ada"
- use gpm && myconf="${myconf} --with-gpm"
# We need the basic terminfo files in /etc, bug #37026. We will
# add '--with-terminfo-dirs' and then populate /etc/terminfo in