summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2012-04-23 19:58:36 +0000
committerVictor Ostorga <vostorga@gentoo.org>2012-04-23 19:58:36 +0000
commit6ccb04de415722dba55b1f3cdf0831ebc8dafac2 (patch)
tree4110b7a61b34850858fb248aa8794fc136f2c244 /sys-libs
parentMarked ~{ppc,x86,x64}-macos, bug #410067 (diff)
downloadgentoo-2-6ccb04de415722dba55b1f3cdf0831ebc8dafac2.tar.gz
gentoo-2-6ccb04de415722dba55b1f3cdf0831ebc8dafac2.tar.bz2
gentoo-2-6ccb04de415722dba55b1f3cdf0831ebc8dafac2.zip
Version bump to 1.2.10
(Portage version: 2.1.10.49/cvs/Linux i686)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/ChangeLog7
-rw-r--r--sys-libs/tdb/tdb-1.2.10.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index 1ff9afb21ce6..383fa69a8dfb 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.41 2012/03/08 06:18:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.42 2012/04/23 19:58:36 vostorga Exp $
+
+*tdb-1.2.10 (23 Apr 2012)
+
+ 23 Apr 2012; Víctor Ostorga <vostorga@gentoo.org> +tdb-1.2.10.ebuild:
+ Version bump to 1.2.10
08 Mar 2012; Patrick Lauer <patrick@gentoo.org> tdb-1.2.9.ebuild:
Python dependency fix
diff --git a/sys-libs/tdb/tdb-1.2.10.ebuild b/sys-libs/tdb/tdb-1.2.10.ebuild
new file mode 100644
index 000000000000..355fab7f694a
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.10.ebuild,v 1.1 2012/04/23 19:58:36 vostorga Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit waf-utils python
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="python"
+
+RDEPEND=""
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}