summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-01-13 18:45:06 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-01-13 18:45:06 +0000
commit60e27e4db91d4bd2262a36666063d3aaebe21e8e (patch)
treea00f6b8216418ac9e2fa6b5c653e233646559252 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-60e27e4db91d4bd2262a36666063d3aaebe21e8e.tar.gz
gentoo-2-60e27e4db91d4bd2262a36666063d3aaebe21e8e.tar.bz2
gentoo-2-60e27e4db91d4bd2262a36666063d3aaebe21e8e.zip
Add new talloc version. NOTE: doc xsl file is fetched from net rather than using the system one, this needs to be fixed.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/ChangeLog10
-rw-r--r--sys-libs/talloc/talloc-2.0.5.ebuild31
2 files changed, 39 insertions, 2 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
index 9f9d5dc8ba9e..9d116074ad95 100644
--- a/sys-libs/talloc/ChangeLog
+++ b/sys-libs/talloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/talloc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.19 2010/09/27 16:30:24 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.20 2011/01/13 18:45:06 scarabeus Exp $
+
+*talloc-2.0.5 (13 Jan 2011)
+
+ 13 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> +talloc-2.0.5.ebuild:
+ Add new talloc version. NOTE: doc xsl file is fetched from net rather than
+ using the system one, this needs to be fixed.
27 Sep 2010; Mart Raudsepp <leio@gentoo.org> talloc-2.0.1-r1.ebuild:
Marked ~mips for bug #285952
diff --git a/sys-libs/talloc/talloc-2.0.5.ebuild b/sys-libs/talloc/talloc-2.0.5.ebuild
new file mode 100644
index 000000000000..af935ca01b59
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.5.ebuild,v 1.1 2011/01/13 18:45:06 scarabeus Exp $
+
+EAPI=3
+
+inherit waf-utils
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="compat python"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_configure() {
+ local extra_opts=""
+
+ use compat && extra_opts+=" --enable-talloc-compat1"
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}