summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 08:01:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 08:01:09 +0000
commit58cc7a39963a95a90d5b19cc05b5067ba310bfdc (patch)
tree81c4375510846eca526662172eaf3cc06130a0f1 /sys-libs
parentremove lots of old gwenhywfar ebuilds (diff)
downloadgentoo-2-58cc7a39963a95a90d5b19cc05b5067ba310bfdc.tar.gz
gentoo-2-58cc7a39963a95a90d5b19cc05b5067ba310bfdc.tar.bz2
gentoo-2-58cc7a39963a95a90d5b19cc05b5067ba310bfdc.zip
remove nested die; tidy
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog6
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild23
2 files changed, 18 insertions, 11 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index fa544337debb..b8bfe01fd424 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.28 2006/03/26 23:00:07 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.29 2006/03/27 08:01:09 mr_bones_ Exp $
+
+ 27 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ gwenhywfar-2.1.1.ebuild:
+ remove nested die; tidy
26 Mar 2006; Hanno Boeck <hanno@gentoo.org> gwenhywfar-2.1.1.ebuild:
Clean up ebuild.
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild
index 7545ba6c1cc1..07e944384c4e 100644
--- a/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild,v 1.2 2006/03/26 23:00:07 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild,v 1.3 2006/03/27 08:01:09 mr_bones_ Exp $
DESCRIPTION="A multi-platform helper library for other libraries"
HOMEPAGE="http://gwenhywfar.sourceforge.net"
@@ -15,21 +15,24 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
sys-libs/ncurses
doc? ( app-doc/doxygen )
ncurses? ( sys-libs/ncurses )"
-S=${WORKDIR}/${P}
src_compile() {
econf \
- `use_enable ssl` \
- `use_enable debug` \
- `use_enable doc full-doc` \
- `use_enable ncurses gwenui` \
- --with-docpath=/usr/share/doc/${P}/apidoc || die "configure failed"
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ $(use_enable ncurses gwenui) \
+ --with-docpath=/usr/share/doc/${PF}/apidoc || die "configure failed"
emake || die "emake failed"
- use doc && (emake srcdoc || die)
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
}
src_install() {
einstall || die
- dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
- use doc && (make DESTDIR=${D} install-srcdoc || die)
+ dodoc README* AUTHORS ChangeLog TODO
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "make isntall-srcdoc failed"
+ fi
}