summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2008-04-27 23:31:14 +0000
committerAlexander Gabert <pappy@gentoo.org>2008-04-27 23:31:14 +0000
commit4bbabd8aca8e8ca6e7f04bc99e9d6ffad90b2035 (patch)
treec4f96bda4734440a871eaea09e1d0d6d6d6cbe2a /sys-libs
parentadding changelog (diff)
downloadgentoo-2-4bbabd8aca8e8ca6e7f04bc99e9d6ffad90b2035.tar.gz
gentoo-2-4bbabd8aca8e8ca6e7f04bc99e9d6ffad90b2035.tar.bz2
gentoo-2-4bbabd8aca8e8ca6e7f04bc99e9d6ffad90b2035.zip
fixed undefined reference to __sync_bool_compare_and_swap_4 by adding -march to CFLAGS
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild b/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild
index 078e9024e8fa..29450c309bfc 100644
--- a/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild
+++ b/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild,v 1.1 2008/04/27 23:17:42 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/hardened-glibc/hardened-glibc-2.6.1-r1.ebuild,v 1.2 2008/04/27 23:31:14 pappy Exp $
inherit eutils
@@ -46,7 +46,10 @@ RDEPEND="sys-devel/gettext"
pkg_setup() {
# hardcoding the CHOST in this ebuild (for x86 stages)
export CHOST="i486-pc-linux-gnu"
- export CFLAGS="-O2 -pipe"
+
+ # CFLAGS+="-march=i686" for undefined reference to
+ # `__sync_bool_compare_and_swap_4'
+ export CFLAGS="-O2 -pipe -march=i686"
export CXXFLAGS="${CFLAGS}"
export CPPFLAGS=""