summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-06-12 06:10:26 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-06-12 06:10:26 +0000
commit3ef005bc1a7a7401f0e44ad4e7caa20c9a69f2c8 (patch)
tree90b727cabf1373fd99a5db4e8fa91323f0219c00 /sys-libs
parentagriffis reminded me of the pcre use flag which is much more accurate. Also, ... (diff)
downloadgentoo-2-3ef005bc1a7a7401f0e44ad4e7caa20c9a69f2c8.tar.gz
gentoo-2-3ef005bc1a7a7401f0e44ad4e7caa20c9a69f2c8.tar.bz2
gentoo-2-3ef005bc1a7a7401f0e44ad4e7caa20c9a69f2c8.zip
Cleanups again, see Changelog for details.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog14
-rw-r--r--sys-libs/glibc/Manifest4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild52
3 files changed, 51 insertions, 19 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index ba9a4c03ae59..537f7449767a 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.187 2004/06/11 09:46:03 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.188 2004/06/12 06:10:26 kumba Exp $
+
+ 12 Jun 2004; Joshua Kinard <kumba@gentoo.org>
+ glibc-2.3.4.20040605-r1.ebuild:
+ - Clean up the usage of paranthesis around groups
+ of use flag checks (unecessarily invokes a subshell)
+ - And allow a sed command that unconditionally disables
+ relro for ld.so to fire (it previously only fired if
+ use build == true or use build == false AND
+ use hardened == true)
+ - Apply one of the mips patches only if use n32 or
+ use n64 is true
+ - Add ~mips to KEYWORDS
11 Jun 2004; Joshua Kinard <kumba@gentoo.org>
glibc-2.3.4.20040605-r1.ebuild:
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 377e370ddca6..b0c7b4903940 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -1,4 +1,4 @@
-MD5 031665d9ac35040ed9f21246066d8cec ChangeLog 38910
+MD5 a4acb351805024d2db1cd18686944df8 ChangeLog 39413
MD5 0fa1291bf0fde4988100d42852d25df6 glibc-2.2.5-r9.ebuild 10001
MD5 6c9ed0aa642c902139be296250465829 glibc-2.3.1-r5.ebuild 10718
MD5 aaa34484bbb3516cc6b220d8345a60d7 glibc-2.3.2-r10.ebuild 19417
@@ -9,7 +9,7 @@ MD5 488e8b7878e9e8a11be594b3e16ee0f4 glibc-2.3.3_pre20031210.ebuild 19014
MD5 22ddf107c3e48edbece07166517dbc7a glibc-2.3.3_pre20040117-r1.ebuild 19231
MD5 67753229fcc7169eb9e648263dfda5f4 glibc-2.3.3_pre20040117.ebuild 18525
MD5 00f71cf6b178a50ca7792b65ebc1f5bc glibc-2.3.3_pre20040207.ebuild 19593
-MD5 c5a37b64ebfb765b0e4b621874c3e459 glibc-2.3.4.20040605-r1.ebuild 16812
+MD5 b35a992f3fb541dd209a4ac497ada443 glibc-2.3.4.20040605-r1.ebuild 17098
MD5 4a439bb638a3309eb4302b0bdc0153da glibc-2.3.3_pre20040420.ebuild 19886
MD5 675c7d0b2383a6e09f765dc23e5cfdec glibc-2.3.3_pre20040529.ebuild 21577
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
index 057427b8127e..22be2577344f 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.3 2004/06/11 09:46:03 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.4 2004/06/12 06:10:26 kumba Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib"
@@ -16,7 +16,7 @@ SRC_URI="http://dev.gentoo.org/~lv/${P}.tar.bz2
HOMEPAGE="http://sources.redhat.com/glibc/"
SLOT="2.2"
LICENSE="LGPL-2"
-KEYWORDS="-*"
+KEYWORDS="-* ~mips"
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -100,17 +100,31 @@ setup_flags() {
want_nptl() {
- (use amd64 || use ppc || use ppc64 || use sparc || use s390 || \
- use ia64 || use alpha) && return 0
- use x86 && if [ "${CHOST/-*}" = "i486" -o "${CHOST/-*}" = "i586" -o \
- "${CHOST/-*}" = "i686" ] ; then return 0 ; fi
+ # Archs that can use NPTL
+ if use amd64 || use alpha || use ia64 || use ppc || \
+ use ppc64 || use s390 || use sparc; then
+ return 0
+ fi
+
+ # Specific x86 CHOSTS that can use NPTL
+ if use x86; then
+ case "${CHOST/-*}" in
+ i486|i586|i686) return 0 ;;
+ esac
+
+ fi
+
return 1
}
want_tls() {
- (use amd64 || use ia64 || use s390 || use alpha || use sparc || \
- use ppc || use ppc64 || use x86) && return 0
+ # Archs that can use TLS (Thread Local Storage)
+ if use amd64 || use alpha || use ia64 || use ppc || \
+ use ppc64 || use s390 || use sparc || use x86; then
+ return 0
+ fi
+
return 1
}
@@ -143,7 +157,7 @@ install_locales() {
setup_locales() {
- if (use nls || use makecheck); then
+ if use nls || use makecheck; then
einfo "nls or makecheck in USE, installing -ALL- locales..."
install_locales
elif [ -e /etc/locales.build ]; then
@@ -189,7 +203,7 @@ pkg_setup() {
echo "yes"
fi
- elif use nptl &> /dev/null; then
+ elif use nptl; then
echo
# Just tell the user not to expect too much ...
ewarn "You have \"nptl\" in your USE, but your kernel version or"
@@ -288,7 +302,10 @@ do_arch_mips_patches() {
epatch ${FILESDIR}/2.3.3/mips-syscall.h.diff
epatch ${FILESDIR}/2.3.3/semtimedop.diff
epatch ${FILESDIR}/2.3.3/mips-sysify.diff
- epatch ${FILESDIR}/2.3.4/mips-sysdep-cancel.diff
+
+ if use n32 || use n64; then
+ epatch ${FILESDIR}/2.3.4/mips-sysdep-cancel.diff
+ fi
# Need to install into /lib for n32-only userland for now.
# Propper solution is to make all userland /lib{32|64}-aware.
@@ -335,10 +352,13 @@ do_hardened_fixes() {
# disable binutils -as-needed
sed -e 's/^have-as-needed.*/have-as-needed = no/' -i ${S}/config.make.in
+ # disable relro usage for ld.so
# mandatory, if binutils supports relro and the kernel is pax/grsecurity enabled
- # solves almost all segfaults building the locale files on grsecurity enabled kernels
- use build && sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig
- use build || (use hardened && sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig)
+ # solves almost all segfaults building the locale files on grsecurity enabled kernels and
+ # Inconsistency detected by ld.so: dl-fini.c: 69: Assertion `i == _rtld_local dl_nloaded' failed!
+ # the real tested conditions, where this definitely has to be applied are for now:
+ # use build || use bootstrap || use hardened || <pax/grsec kernel>
+ sed -e 's/^LDFLAGS-rtld += $(relro.*/LDFLAGS-rtld += -Wl,-z,norelro/' -i ${S}/Makeconfig
# disables building nscd as pie
use hardened || sed -e 's/^have-fpie.*/have-fpie = no/' -i ${S}/config.make.in
@@ -429,7 +449,7 @@ src_compile() {
use erandom || myconf="${myconf} --disable-dev-erandom"
use hardened && myconf="${myconf} --enable-bind-now"
- if (use nptl && want_nptl && want_tls); then
+ if use nptl && want_nptl && want_tls; then
myconf="${myconf} \
--enable-add-ons=nptl \
--with-tls --with-__thread \
@@ -528,7 +548,7 @@ EOF
timezone/install-others -C ${WORKDIR}/build || die
fi
- if (use pic && use !amd64); then
+ if use pic && use !amd64; then
find ${S}/${buildtarget}/ -name "soinit.os" -exec cp {} ${D}/lib/soinit.o \;
find ${S}/${buildtarget}/ -name "sofini.os" -exec cp {} ${D}/lib/sofini.o \;
find ${S}/${buildtarget}/ -name "*_pic.a" -exec cp {} ${D}/lib \;