summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-17 00:46:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-17 00:46:54 +0000
commit1c9081f17363652994a20cb1f8cade68adb760c9 (patch)
tree4a54c546c512d459b826fdcc163b35cb83230508 /sys-libs
parentKevin F. Quinn: fix PaX support #115100. (diff)
downloadgentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.tar.gz
gentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.tar.bz2
gentoo-2-1c9081f17363652994a20cb1f8cade68adb760c9.zip
fix header searching when emerging into an empty ROOT #114923
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r1.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild12
-rw-r--r--sys-libs/glibc/glibc-2.3.6.ebuild7
6 files changed, 34 insertions, 13 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r1.ebuild b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
index 13a33cace184..2b8f793629be 100644
--- a/sys-libs/glibc/glibc-2.3.5-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.46 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r1.ebuild,v 1.47 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -897,6 +897,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -904,7 +907,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index 86e307c2b02e..e0a7ba45fa9d 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.21 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.22 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -904,6 +904,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -911,7 +914,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index 5452ed2086db..1f7ca9a0ba2c 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.9 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.10 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -909,6 +909,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -916,7 +919,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index b97ffcc4c6a9..2135ff64f1b7 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.49 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.50 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -922,6 +922,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -929,7 +932,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index bd80cdd9aead..1fe66b694f74 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.6 2005/12/09 20:32:39 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.7 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -257,6 +257,9 @@ toolchain-glibc_headers_compile() {
mkdir -p "${GBUILDDIR}"
cd "${GBUILDDIR}"
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
local myconf="--disable-sanity-checks --enable-hacker-mode"
myconf="${myconf}
--enable-add-ons=linuxthreads
@@ -264,7 +267,7 @@ toolchain-glibc_headers_compile() {
--enable-bind-now
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
@@ -958,6 +961,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -965,7 +971,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.6.ebuild b/sys-libs/glibc/glibc-2.3.6.ebuild
index b4199ddd5bf8..ff5f5e833092 100644
--- a/sys-libs/glibc/glibc-2.3.6.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.8 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.9 2005/12/17 00:46:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -922,6 +922,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -929,7 +932,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info