summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-11 16:45:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-11 16:45:50 +0000
commit9f0955cbcdc984b5cddc81193f91b4d213dc9684 (patch)
treeea322de79768d82e6a75b0129d1cd9b3a356a2d5 /sys-libs/uclibc++
parentStable on amd64, bug 114429. (diff)
downloadgentoo-2-9f0955cbcdc984b5cddc81193f91b4d213dc9684.tar.gz
gentoo-2-9f0955cbcdc984b5cddc81193f91b4d213dc9684.tar.bz2
gentoo-2-9f0955cbcdc984b5cddc81193f91b4d213dc9684.zip
old
Diffstat (limited to 'sys-libs/uclibc++')
-rw-r--r--sys-libs/uclibc++/files/0.1.8-pop_back.patch17
-rw-r--r--sys-libs/uclibc++/files/digest-uclibc++-0.1.81
-rw-r--r--sys-libs/uclibc++/files/digest-uclibc++-0.1.91
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.8.ebuild77
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.9.ebuild74
5 files changed, 0 insertions, 170 deletions
diff --git a/sys-libs/uclibc++/files/0.1.8-pop_back.patch b/sys-libs/uclibc++/files/0.1.8-pop_back.patch
deleted file mode 100644
index aed5aa970e87..000000000000
--- a/sys-libs/uclibc++/files/0.1.8-pop_back.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: string
-===================================================================
-RCS file: /var/cvs/uClibc++/include/string,v
-retrieving revision 1.15
-retrieving revision 1.16
-diff -u -r1.15 -r1.16
---- include/string 9 Jan 2005 06:10:45 -0000 1.15
-+++ include/string 9 Jan 2005 21:58:36 -0000 1.16
-@@ -354,7 +354,7 @@
- ++position;
- }
- // --vector<Ch, A>::elements;
-- pop_back();
-+ vector<Ch, A>::pop_back();
- return temp;
- }
-
diff --git a/sys-libs/uclibc++/files/digest-uclibc++-0.1.8 b/sys-libs/uclibc++/files/digest-uclibc++-0.1.8
deleted file mode 100644
index 4eee99fab83c..000000000000
--- a/sys-libs/uclibc++/files/digest-uclibc++-0.1.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c15b4c6680a9f7e9d4d822409003be3c uClibc++-0.1.8.tbz2 248904
diff --git a/sys-libs/uclibc++/files/digest-uclibc++-0.1.9 b/sys-libs/uclibc++/files/digest-uclibc++-0.1.9
deleted file mode 100644
index 7479beca3a0f..000000000000
--- a/sys-libs/uclibc++/files/digest-uclibc++-0.1.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ebf58e04d72eab5c131c2c9118737024 uClibc++-0.1.9.tbz2 248796
diff --git a/sys-libs/uclibc++/uclibc++-0.1.8.ebuild b/sys-libs/uclibc++/uclibc++-0.1.8.ebuild
deleted file mode 100644
index d4a3c3bb1a4c..000000000000
--- a/sys-libs/uclibc++/uclibc++-0.1.8.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.8.ebuild,v 1.3 2005/01/12 04:26:57 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="embedded C++ library"
-HOMEPAGE="http://cxx.uclibc.org/"
-SRC_URI="http://cxx.uclibc.org/src/uClibc++-${PV}.tbz2"
-
-LICENSE="GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~arm ~ppc ~x86"
-IUSE="debug static"
-
-DEPEND=""
-
-S=${WORKDIR}/uClibc++
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- make defconfig || die "defconfig failed"
-
- local target
- case $(tc-arch ${CTARGET}) in
- arm) target="arm";;
- mips) target="mips";;
- ppc) target="powerpc";;
- x86) target="i386";;
- *) die "$(tc-arch ${CTARGET}) lists no defaults :/";;
- esac
-
- sed -i \
- -e '/^UCLIBCXX_RUNTIME_PREFIX=/d' \
- -e '/^TARGET_'${target}'/d' \
- .config
-
- echo "UCLIBCXX_RUNTIME_PREFIX=\"/usr/${CTARGET}\"" >> .config
- echo "TARGET_${target}=y" >> .config
- use debug && echo "CONFIG_DODEBUG=y" >> .config
-
- yes "" | make oldconfig || die "oldconfig failed"
-
- # has to come after make oldconfig, else it will be disabled
- echo "BUILD_STATIC_LIB=y" >> .config
- if use static ; then
- echo "BUILD_ONLY_STATIC_LIB=y" >> .config
- fi
-
- # Patches!
- epatch "${FILESDIR}"/${PV}-pop_back.patch
-}
-
-src_compile() {
- emake -j1 ARCH_CFLAGS="${CFLAGS}" CROSS=${CTARGET}- || die "make failed"
-}
-
-src_test() {
- make test || die "test failed"
-}
-
-src_install() {
- make install PREFIX="${D}" || die
- dodir /usr/bin
- dosym /usr/${CTARGET}/bin/g++-uc /usr/bin/g++-uc
- dodoc ChangeLog README TODO
-}
diff --git a/sys-libs/uclibc++/uclibc++-0.1.9.ebuild b/sys-libs/uclibc++/uclibc++-0.1.9.ebuild
deleted file mode 100644
index bfb538add994..000000000000
--- a/sys-libs/uclibc++/uclibc++-0.1.9.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.9.ebuild,v 1.1 2005/01/22 05:21:29 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-DESCRIPTION="embedded C++ library"
-HOMEPAGE="http://cxx.uclibc.org/"
-SRC_URI="http://cxx.uclibc.org/src/uClibc++-${PV}.tbz2"
-
-LICENSE="GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~arm ~ppc ~x86"
-IUSE="debug static"
-
-DEPEND=""
-
-S=${WORKDIR}/uClibc++
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- make defconfig || die "defconfig failed"
-
- local target
- case $(tc-arch ${CTARGET}) in
- arm) target="arm";;
- mips) target="mips";;
- ppc) target="powerpc";;
- x86) target="i386";;
- *) die "$(tc-arch ${CTARGET}) lists no defaults :/";;
- esac
-
- sed -i \
- -e '/^UCLIBCXX_RUNTIME_PREFIX=/d' \
- -e '/^TARGET_'${target}'/d' \
- .config
-
- echo "UCLIBCXX_RUNTIME_PREFIX=\"/usr/${CTARGET}\"" >> .config
- echo "TARGET_${target}=y" >> .config
- use debug && echo "CONFIG_DODEBUG=y" >> .config
-
- yes "" | make oldconfig || die "oldconfig failed"
-
- # has to come after make oldconfig, else it will be disabled
- echo "BUILD_STATIC_LIB=y" >> .config
- if use static ; then
- echo "BUILD_ONLY_STATIC_LIB=y" >> .config
- fi
-}
-
-src_compile() {
- emake -j1 ARCH_CFLAGS="${CFLAGS}" CROSS=${CTARGET}- || die "make failed"
-}
-
-src_test() {
- make test || die "test failed"
-}
-
-src_install() {
- make install PREFIX="${D}" || die
- dodir /usr/bin
- dosym /usr/${CTARGET}/bin/g++-uc /usr/bin/g++-uc
- dodoc ChangeLog README TODO
-}