summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-26 22:04:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-26 22:04:08 +0000
commite9ace23168aaab2aa0d0c1f297ad372c84fec6ba (patch)
treedb0003bedab3946c759fec4c4b575ee0be5f84b1 /sys-libs/talloc
parentFixing init script for extra opts (diff)
downloadgentoo-2-e9ace23168aaab2aa0d0c1f297ad372c84fec6ba.tar.gz
gentoo-2-e9ace23168aaab2aa0d0c1f297ad372c84fec6ba.tar.bz2
gentoo-2-e9ace23168aaab2aa0d0c1f297ad372c84fec6ba.zip
Bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/talloc')
-rw-r--r--sys-libs/talloc/ChangeLog9
-rw-r--r--sys-libs/talloc/talloc-2.0.1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
index 98002eeaeae1..5f9c92224396 100644
--- a/sys-libs/talloc/ChangeLog
+++ b/sys-libs/talloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/talloc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.10 2009/12/06 17:14:48 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.11 2010/01/26 22:04:08 patrick Exp $
+
+*talloc-2.0.1 (26 Jan 2010)
+
+ 26 Jan 2010; Patrick Lauer <patrick@gentoo.org> +talloc-2.0.1.ebuild:
+ Bump
06 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
talloc-2.0.0-r1.ebuild:
diff --git a/sys-libs/talloc/talloc-2.0.1.ebuild b/sys-libs/talloc/talloc-2.0.1.ebuild
new file mode 100644
index 000000000000..930f614ad5eb
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.1.ebuild,v 1.1 2010/01/26 22:04:08 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils autotools
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/talloc/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="compat doc"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="!<net-fs/samba-3.3
+ doc? ( app-text/docbook-xml-dtd:4.2 )
+ !<net-fs/samba-libs-3.4
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${PN}-2.0.0-without-doc.patch
+ eautoconf -Ilibreplace
+ sed -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' -i Makefile.in
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable compat talloc-compat1) \
+ $(use_with doc) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+
+}
+
+src_install() {
+
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dolib.a sharedbuild/lib/libtalloc.a
+ dolib.so sharedbuild/lib/libtalloc.so
+
+}