summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-20 22:15:20 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-20 22:15:20 +0000
commitcb5d3f4b9e6b0d2b21b4f55d92c9c86773733c4f (patch)
treeb5630f8d9ef66eff580f996e4406e641b9628f31 /sys-libs/newlib
parentversion bump (bug #447982) (diff)
downloadgentoo-2-cb5d3f4b9e6b0d2b21b4f55d92c9c86773733c4f.tar.gz
gentoo-2-cb5d3f4b9e6b0d2b21b4f55d92c9c86773733c4f.tar.bz2
gentoo-2-cb5d3f4b9e6b0d2b21b4f55d92c9c86773733c4f.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog8
-rw-r--r--sys-libs/newlib/newlib-2.0.0.ebuild72
2 files changed, 78 insertions, 2 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index 1bac5a612e95..7aba437ee5da 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.19 2012/11/20 14:21:39 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.20 2012/12/20 22:15:20 vapier Exp $
+
+*newlib-2.0.0 (20 Dec 2012)
+
+ 20 Dec 2012; Mike Frysinger <vapier@gentoo.org> +newlib-2.0.0.ebuild:
+ Version bump.
20 Nov 2012; Luca Barbato <lu_zero@gentoo.org> newlib-1.18.0.ebuild,
newlib-1.19.0.ebuild, newlib-1.20.0.ebuild:
@@ -87,4 +92,3 @@
21 Aug 2006; Luca Barbato <lu_zero@gentoo.org> +metadata.xml,
+newlib-1.14.0.ebuild:
Import from overlay
-
diff --git a/sys-libs/newlib/newlib-2.0.0.ebuild b/sys-libs/newlib/newlib-2.0.0.ebuild
new file mode 100644
index 000000000000..026747593feb
--- /dev/null
+++ b/sys-libs/newlib/newlib-2.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.0.0.ebuild,v 1.1 2012/12/20 22:15:20 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls threads unicode crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+NEWLIBBUILD="${WORKDIR}/build"
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|*-elf) ;;
+ *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-newlib-multithread" \
+ || myconf="${myconf} $(use_enable threads newlib-multithread)"
+
+ mkdir -p "${NEWLIBBUILD}"
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${NEWLIBBUILD}"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}