summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-10-25 06:24:24 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-10-25 06:24:24 +0000
commitc5301e77802aadfbd8a82478925fb764c8fec986 (patch)
treedc6adc1462b989313ce8597ecbf1ef2041765d80 /sys-libs/newlib
parentusing SITELISP variable from elisp.eclass instead of hard-coded path (diff)
downloadgentoo-2-c5301e77802aadfbd8a82478925fb764c8fec986.tar.gz
gentoo-2-c5301e77802aadfbd8a82478925fb764c8fec986.tar.bz2
gentoo-2-c5301e77802aadfbd8a82478925fb764c8fec986.zip
New snapshot, avoid strip completely
(Portage version: 2.1.3.15)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog8
-rw-r--r--sys-libs/newlib/files/digest-newlib-1.16.0_pre200710253
-rw-r--r--sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild75
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index 8627522c404e..daf29f5910ca 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.9 2007/03/19 15:50:47 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.10 2007/10/25 06:24:23 lu_zero Exp $
+
+*newlib-1.16.0_pre20071025 (25 Oct 2007)
+
+ 25 Oct 2007; Luca Barbato <lu_zero@gentoo.org>
+ +newlib-1.16.0_pre20071025.ebuild:
+ New snapshot, avoid strip completely
19 Mar 2007; Luca Barbato <lu_zero@gentoo.org> newlib-1.15.0.ebuild:
Removed multilib useflag
diff --git a/sys-libs/newlib/files/digest-newlib-1.16.0_pre20071025 b/sys-libs/newlib/files/digest-newlib-1.16.0_pre20071025
new file mode 100644
index 000000000000..849028a35948
--- /dev/null
+++ b/sys-libs/newlib/files/digest-newlib-1.16.0_pre20071025
@@ -0,0 +1,3 @@
+MD5 54afe931cd1748266bd98da924e72515 newlib-1.16.0_pre20071025.tar.bz2 7524018
+RMD160 1229d4d41d9309ddcf387fe0c7f641cfd6f18d01 newlib-1.16.0_pre20071025.tar.bz2 7524018
+SHA256 4687572a42b7168a97e4540901b7651335cd8cbc07df4cc3e1c5c3525bd53384 newlib-1.16.0_pre20071025.tar.bz2 7524018
diff --git a/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild b/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild
new file mode 100644
index 000000000000..bb773cf56791
--- /dev/null
+++ b/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.16.0_pre20071025.ebuild,v 1.1 2007/10/25 06:24:23 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+# Handle the case where we want newlib on glibc ...
+if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
+ export CTARGET=${CHOST%%-*}-pc-linux-newlib
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls threads unicode"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND=""
+
+NEWLIBBUILD="${WORKDIR}/build"
+S="${WORKDIR}/newlib"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${NEWLIBBUILD}"
+}
+
+src_compile() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ # hardwired to avoid breakages
+ [[ $(tc-is-softfloat) != "no" ]] \
+ && myconf="--disable-newlib-hw-fp" \
+ || myconf="--enable-newlib-hw-fp"
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-threads" \
+ || myconf="${myconf} $(use_enable threads)"
+
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}