summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-08 03:13:11 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-08 03:13:11 +0000
commit1ae31200732e25c66e637fda5d87d0dfb9588e8d (patch)
tree5af826ca6239368c69600761fc456d1c1caeba40 /sys-libs/ncurses
parentAdd py3.4 support, rm old (diff)
downloadgentoo-2-1ae31200732e25c66e637fda5d87d0dfb9588e8d.tar.gz
gentoo-2-1ae31200732e25c66e637fda5d87d0dfb9588e8d.tar.bz2
gentoo-2-1ae31200732e25c66e637fda5d87d0dfb9588e8d.zip
Convert configure flags to an array to make management easier. Fix pkg-config file install when cross-compiling or installing for the first time.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ChangeLog7
-rw-r--r--sys-libs/ncurses/files/ncurses-5.9-pkg-config.patch26
-rw-r--r--sys-libs/ncurses/ncurses-5.9-r3.ebuild104
3 files changed, 87 insertions, 50 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 0a2c5803e6be..6053536fb870 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/ncurses
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.217 2014/01/18 02:22:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.218 2014/04/08 03:13:11 vapier Exp $
+
+ 08 Apr 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/ncurses-5.9-pkg-config.patch, ncurses-5.9-r3.ebuild:
+ Convert configure flags to an array to make management easier. Fix pkg-config
+ file install when cross-compiling or installing for the first time.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> ncurses-5.9-r2.ebuild,
ncurses-5.9-r3.ebuild:
diff --git a/sys-libs/ncurses/files/ncurses-5.9-pkg-config.patch b/sys-libs/ncurses/files/ncurses-5.9-pkg-config.patch
new file mode 100644
index 000000000000..7c3c04a449f8
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-5.9-pkg-config.patch
@@ -0,0 +1,26 @@
+disable the $PATH search for the PKG_CONFIG tool. it isn't needed and just
+gets in the way when setting to a value that might not yet exist.
+
+disable the existence test for the PKG_CONFIG_LIBDIR dir. it breaks when you
+cross-compile for an ABI that doesn't exist in the root dir (--build).
+
+--- a/configure
++++ b/configure
+@@ -3582,7 +3582,7 @@ fi
+ esac
+
+ test -z "$PKG_CONFIG" && PKG_CONFIG=none
+-if test "$PKG_CONFIG" != none ; then
++if false ; then
+
+ if test "x$prefix" != xNONE; then
+ cf_path_syntax="$prefix"
+@@ -3626,7 +3626,7 @@ echo $ECHO_N "checking if we should install .pc files for $PKG_CONFIG... $ECHO_C
+ PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG" | sed -e 's,/[^/]*/[^/]*$,,'`/lib/pkgconfig
+ fi
+ PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG_LIBDIR" | sed -e 's/^://' -e 's/:.*//'`
+- if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then
++ if test -n "$PKG_CONFIG_LIBDIR" ; then
+
+ # Check whether --enable-pc-files or --disable-pc-files was given.
+ if test "${enable_pc_files+set}" = set; then
diff --git a/sys-libs/ncurses/ncurses-5.9-r3.ebuild b/sys-libs/ncurses/ncurses-5.9-r3.ebuild
index c178d8a49521..e2ffdf2553f0 100644
--- a/sys-libs/ncurses/ncurses-5.9-r3.ebuild
+++ b/sys-libs/ncurses/ncurses-5.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.9-r3.ebuild,v 1.4 2014/01/18 02:22:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.9-r3.ebuild,v 1.5 2014/04/08 03:13:11 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic toolchain-funcs multilib-minimal
@@ -39,6 +39,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
epatch "${FILESDIR}"/${PN}-5.9-rxvt-unicode-9.15.patch #192083 #383871
epatch "${FILESDIR}"/${PN}-5.9-fix-clang-build.patch #417763
+ epatch "${FILESDIR}"/${PN}-5.9-pkg-config.patch
}
src_configure() {
@@ -72,54 +73,59 @@ do_configure() {
cd "${BUILD_DIR}"-$1 || die
shift
- # ncurses is dumb and doesn't install .pc files unless pkg-config
- # is also installed. Force the tests to go our way. Note that it
- # doesn't actually use pkg-config ... it just looks for set vars.
- tc-export PKG_CONFIG
- export PKG_CONFIG_LIBDIR="/usr/$(get_libdir)/pkgconfig"
-
- # The chtype/mmask-t settings below are to retain ABI compat
- # with ncurses-5.4 so dont change em !
- local conf_abi="
- --with-chtype=long \
- --with-mmask-t=long \
- --disable-ext-colors \
- --disable-ext-mouse \
- --without-pthread \
- --without-reentrant \
- "
- # We need the basic terminfo files in /etc, bug #37026. We will
- # add '--with-terminfo-dirs' and then populate /etc/terminfo in
- # src_install() ...
-# $(use_with berkdb hashed-db)
- econf \
- --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo" \
- --with-shared \
- --without-hashed-db \
- $(use_with ada) \
- $(use_with cxx) \
- $(use_with cxx cxx-binding) \
- $(use_with debug) \
- $(use_with profile) \
- $(use_with gpm) \
- $(multilib_is_native_abi || use_with gpm gpm libgpm.so.1) \
- --disable-termcap \
- --enable-symlinks \
- --with-rcs-ids \
- --with-manpage-format=normal \
- --enable-const \
- --enable-colorfgbg \
- --enable-echo \
- --enable-pc-files \
- $(use_enable !ada warnings) \
- $(use_with debug assertions) \
- $(use_enable debug leaks) \
- $(use_with debug expanded) \
- $(use_with !debug macros) \
- $(use_with trace) \
- $(use_with tinfo termlib) \
- ${conf_abi} \
- "$@"
+ local conf=(
+ # We need the basic terminfo files in /etc, bug #37026. We will
+ # add '--with-terminfo-dirs' and then populate /etc/terminfo in
+ # src_install() ...
+ --with-terminfo-dirs="/etc/terminfo:/usr/share/terminfo"
+
+ # Disabled until #245417 is sorted out.
+ #$(use_with berkdb hashed-db)
+
+ # ncurses is dumb and doesn't install .pc files unless pkg-config
+ # is also installed. Force the tests to go our way. Note that it
+ # doesn't actually use pkg-config ... it just looks for set vars.
+ --enable-pc-files
+ --with-pkg-config="$(tc-getPKG_CONFIG)"
+ # This path is used to control where the .pc files are installed.
+ PKG_CONFIG_LIBDIR="/usr/$(get_libdir)/pkgconfig"
+
+ # Now the rest of the various standard flags.
+ --with-shared
+ --without-hashed-db
+ $(use_with ada)
+ $(use_with cxx)
+ $(use_with cxx cxx-binding)
+ $(use_with debug)
+ $(use_with profile)
+ $(use_with gpm)
+ $(multilib_is_native_abi || use_with gpm gpm libgpm.so.1)
+ --disable-termcap
+ --enable-symlinks
+ --with-rcs-ids
+ --with-manpage-format=normal
+ --enable-const
+ --enable-colorfgbg
+ --enable-echo
+ $(use_enable !ada warnings)
+ $(use_with debug assertions)
+ $(use_enable debug leaks)
+ $(use_with debug expanded)
+ $(use_with !debug macros)
+ $(use_with trace)
+ $(use_with tinfo termlib)
+
+ # The chtype/mmask-t settings below are to retain ABI compat
+ # with ncurses-5.4 so dont change em !
+ --with-chtype=long
+ --with-mmask-t=long
+ --disable-ext-colors
+ --disable-ext-mouse
+ --without-pthread
+ --without-reentrant
+ )
+
+ econf "${conf[@]}" "$@"
}
src_compile() {