summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-10-03 03:26:17 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-10-03 03:26:17 +0000
commita66dc4a69289c1701d987a0f7af036f5564e7e66 (patch)
tree4b3b14627f32df38602c4476ca8f997f92b2e267 /sys-libs/libsemanage/libsemanage-2.0.27.ebuild
parentInitial commit of 2.0 libselinux. (diff)
downloadgentoo-2-a66dc4a69289c1701d987a0f7af036f5564e7e66.tar.gz
gentoo-2-a66dc4a69289c1701d987a0f7af036f5564e7e66.tar.bz2
gentoo-2-a66dc4a69289c1701d987a0f7af036f5564e7e66.zip
Initial commit of 2.0 libsemanage.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r3 x86_64)
Diffstat (limited to 'sys-libs/libsemanage/libsemanage-2.0.27.ebuild')
-rw-r--r--sys-libs/libsemanage/libsemanage-2.0.27.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-libs/libsemanage/libsemanage-2.0.27.ebuild b/sys-libs/libsemanage/libsemanage-2.0.27.ebuild
new file mode 100644
index 000000000000..dad2dbbed9ec
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.0.27.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/libsemanage-2.0.27.ebuild,v 1.1 2008/10/03 03:26:17 pebenito Exp $
+
+IUSE=""
+
+inherit eutils multilib python
+
+# BUGFIX_PATCH="${FILESDIR}/libsemanage-1.6.6.diff"
+
+SEPOL_VER="2.0"
+SELNX_VER="2.0"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/current/devel/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+DEPEND="=sys-libs/libsepol-${SEPOL_VER}*
+ =sys-libs/libselinux-${SELNX_VER}*
+ dev-libs/ustr"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+
+ # fix up paths for multilib
+ sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib LIBDIR failed."
+ sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
+ || die "Fix for multilib SHLIBDIR failed."
+}
+
+src_compile() {
+ python_version
+ emake PYLIBVER="python${PYVER}" all || die
+ emake PYLIBVER="python${PYVER}" pywrap || die
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" PYLIBVER="python${PYVER}" install install-pywrap
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
+}