summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-07-25 21:34:00 +0000
committerTim Harder <radhermit@gentoo.org>2012-07-25 21:34:00 +0000
commit13220f4d49e3e87371e7279659603af420cc2f2a (patch)
treee49f2426bddc9ca2fab94b7082eb2f7e277e5dba /sys-libs/libcap-ng
parentFix ChangeLog (diff)
downloadgentoo-2-13220f4d49e3e87371e7279659603af420cc2f2a.tar.gz
gentoo-2-13220f4d49e3e87371e7279659603af420cc2f2a.tar.bz2
gentoo-2-13220f4d49e3e87371e7279659603af420cc2f2a.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libcap-ng')
-rw-r--r--sys-libs/libcap-ng/ChangeLog7
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.ebuild115
2 files changed, 121 insertions, 1 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 7ae940ad50c0..f4e6512720a2 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.47 2012/05/19 12:46:28 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.48 2012/07/25 21:34:00 radhermit Exp $
+
+*libcap-ng-0.7 (25 Jul 2012)
+
+ 25 Jul 2012; Tim Harder <radhermit@gentoo.org> +libcap-ng-0.7.ebuild:
+ Version bump.
19 May 2012; Anthony G. Basile <blueness@gentoo.org> libcap-ng-0.6.6.ebuild:
Keyword mips
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.ebuild
new file mode 100644
index 000000000000..697248780f97
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.ebuild,v 1.1 2012/07/25 21:34:00 radhermit Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+
+inherit autotools eutils flag-o-matic python
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="python static-libs"
+
+RDEPEND="sys-apps/attr
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ # Disable byte-compilation of Python modules.
+ >py-compile
+
+ # Python bindings are built/tested/installed manually.
+ sed -i -e "/^SUBDIRS/s/ python//" bindings/Makefile.am || die
+
+ eautoreconf
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with python)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources bindings/python
+
+ building() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir bindings/python building
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ default
+
+ if use python; then
+ testing() {
+ emake \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ TESTS_ENVIRONMENT="PYTHONPATH=..:../.libs" \
+ check
+ }
+ python_execute_function -s --source-dir bindings/python testing
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="$(python_get_version)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir bindings/python installation
+
+ python_clean_installation_image
+ fi
+
+ rm -f "${ED}"/usr/lib*/${PN}.la
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize capng.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup capng.py
+}