summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-12 06:22:40 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-12 06:22:40 +0000
commite4210c232bdd50576ea34bb37d83cade3e3fb04b (patch)
tree9c1e47caa64030b6188ce59f3bee897ba58ceba5 /sys-libs/glibc
parentNew snapshot, bug 333633. (diff)
downloadgentoo-2-e4210c232bdd50576ea34bb37d83cade3e3fb04b.tar.gz
gentoo-2-e4210c232bdd50576ea34bb37d83cade3e3fb04b.tar.bz2
gentoo-2-e4210c232bdd50576ea34bb37d83cade3e3fb04b.zip
Drop useless eselect-compiler logic and notify the world of our explicit CC setup.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit5
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 486324685c1f..d3ede808d194 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.711 2010/08/24 02:26:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.712 2010/09/12 06:22:40 vapier Exp $
+
+ 12 Sep 2010; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit:
+ Drop useless eselect-compiler logic and notify the world of our explicit CC
+ setup.
24 Aug 2010; Mike Frysinger <vapier@gentoo.org> glibc-2.12.1-r1.ebuild:
Fix gnu indirect checks with older binutils #333541 by biohazrd.
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 19ae7a840fef..ff651e62bc4d 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.11 2010/08/10 08:08:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.12 2010/09/12 06:22:40 vapier Exp $
glibc_do_configure() {
local myconf
@@ -89,7 +89,8 @@ glibc_do_configure() {
# since the glibc build will re-run configure on itself
export libc_cv_slibdir=/$(get_libdir)
- has_version app-admin/eselect-compiler || export CC=$(tc-getCC ${CTARGET})
+ export CC=$(tc-getCC ${CTARGET})
+ einfo "Set CC to ${CC}"
local GBUILDDIR=${WORKDIR}/build-${ABI}-${CTARGET}-$1
mkdir -p "${GBUILDDIR}"