summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-11 11:53:06 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-11 11:53:06 +0000
commit4bb4e6b009e76edfb4da629bcc683a5442d93d78 (patch)
tree0b97a83ec2bbee937a58600443838988701c2e6d /sys-libs/glibc
parentemul-linux-x86 update (Manifest recommit) (diff)
downloadgentoo-2-4bb4e6b009e76edfb4da629bcc683a5442d93d78.tar.gz
gentoo-2-4bb4e6b009e76edfb4da629bcc683a5442d93d78.tar.bz2
gentoo-2-4bb4e6b009e76edfb4da629bcc683a5442d93d78.zip
emul-linux-x86 updates.
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild16
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild16
2 files changed, 18 insertions, 14 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 52cb30691598..04eec2ce1405 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.25 2005/01/11 02:42:26 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.26 2005/01/11 11:53:05 eradicator Exp $
inherit eutils flag-o-matic gcc versionator
@@ -53,7 +53,7 @@ LICENSE="LGPL-2"
#~sparc: This is only used by the sparc64-multilib PROFILE_ARCH as versions
# after ~2.3.3.20040420 break blackdown-jdk on sparc.
KEYWORDS="x86 amd64 hppa ppc64 ~ppc -mips ~sparc"
-IUSE="nls pic build nptl erandom hardened multilib debug userlocales"
+IUSE="nls pic build nptl erandom hardened multilib debug userlocales emul-linux-x86"
RESTRICT="nostrip multilib-pkg" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -70,7 +70,7 @@ RDEPEND="virtual/os-headers
sys-apps/baselayout
nls? ( sys-devel/gettext )"
# until we compile the 32bit glibc here
-PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
+PDEPEND="emul-linux-x86? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
PROVIDE="virtual/glibc virtual/libc"
@@ -609,13 +609,14 @@ src_unpack() {
src_compile() {
if [ -n "${MULTILIB_ABIS}" -a -z "${OABI}" ] && ! hasq multilib-pkg ${FEATURES}; then
- OABI="${ABI}"
+ local OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
export ABI
einfo "Compiling ${ABI} glibc"
src_compile && mv ${WORKDIR}/build ${WORKDIR}/build.${ABI}
done
ABI="${OABI}"
+ unset OABI
return 0
fi
@@ -674,7 +675,7 @@ src_compile() {
src_install() {
if [ -n "${MULTILIB_ABIS}" -a -z "${OABI}" ] && ! hasq multilib-pkg ${FEATURES}; then
- OABI="${ABI}"
+ local OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
export ABI
mv ${WORKDIR}/build.${ABI} ${WORKDIR}/build
@@ -691,8 +692,9 @@ src_install() {
fi
done
- return 0
ABI="${OABI}"
+ unset OABI
+ return 0
fi
setup_flags
@@ -799,7 +801,7 @@ EOF
rm -f ${D}/etc/localtime
# Some things want this, notably ash.
- dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
+ dosym /usr/$(get_libdir)/libbsd-compat.a /usr/$(get_libdir)/libbsd.a
# This is our new config file for building locales
insinto /etc
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index d12b2edd4cb9..e4c7f7515921 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.19 2005/01/11 02:42:26 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.20 2005/01/11 11:53:06 eradicator Exp $
inherit eutils flag-o-matic gcc versionator
@@ -53,7 +53,7 @@ LICENSE="LGPL-2"
#-sparc: Compiled fine with 3.4.1-r1, but tar would consistantly bus error when untarring the
# samba-1.0.9 tarball.
KEYWORDS="~amd64 ppc64 -hppa ~ia64 ~ppc ~x86 ~mips -sparc"
-IUSE="nls pic build nptl nptlonly erandom hardened multilib debug userlocales nomalloccheck"
+IUSE="nls pic build nptl nptlonly erandom hardened multilib debug userlocales nomalloccheck emul-linux-x86"
RESTRICT="nostrip multilib-pkg" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -70,7 +70,7 @@ RDEPEND="virtual/os-headers
sys-apps/baselayout
nls? ( sys-devel/gettext )"
# until we compile the 32bit glibc here
-PDEPEND="amd64? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
+PDEPEND="emul-linux-x86? ( multilib? ( app-emulation/emul-linux-x86-glibc ) )"
PROVIDE="virtual/glibc virtual/libc"
@@ -451,7 +451,7 @@ do_arch_ppc64_patches() {
# Any needed patches for ppc64 go here
# setup lib -- seems like a good place to set this up
- get_libdir_override lib64
+ [ -z "${MULTILIB_ABIS}" ] && get_libdir_override lib64
}
@@ -693,13 +693,14 @@ glibc_do_configure() {
src_compile() {
if [ -n "${MULTILIB_ABIS}" -a -z "${OABI}" ] && ! hasq multilib-pkg ${FEATURES}; then
- OABI="${ABI}"
+ local OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
export ABI
einfo "Compiling ${ABI} glibc"
src_compile && mv ${WORKDIR}/build ${WORKDIR}/build.${ABI}
done
ABI="${OABI}"
+ unset OABI
return 0
fi
@@ -720,7 +721,7 @@ src_compile() {
src_install() {
if [ -n "${MULTILIB_ABIS}" -a -z "${OABI}" ] && ! hasq multilib-pkg ${FEATURES}; then
- OABI="${ABI}"
+ local OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
export ABI
mv ${WORKDIR}/build.${ABI} ${WORKDIR}/build
@@ -738,6 +739,7 @@ src_install() {
done
ABI="${OABI}"
+ unset OABI
return 0
fi
@@ -919,7 +921,7 @@ EOF
rm -f ${D}/etc/localtime
# Some things want this, notably ash.
- dosym /usr/lib/libbsd-compat.a /usr/lib/libbsd.a
+ dosym /usr/$(get_libdir)/libbsd-compat.a /usr/$(get_libdir)/libbsd.a
insinto /etc
# This is our new config file for building locales