summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-20 00:48:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-20 00:48:02 +0000
commit8dd7901736801034f459255820a99e4f1d3c9bfa (patch)
tree600d1d6251328216313f59aa5fa34a6ab51dbc95 /sys-libs/glibc/glibc-2.3.2-r9.ebuild
parentfixed bugs #38482, #37619, #32523. (Manifest recommit) (diff)
downloadgentoo-2-8dd7901736801034f459255820a99e4f1d3c9bfa.tar.gz
gentoo-2-8dd7901736801034f459255820a99e4f1d3c9bfa.tar.bz2
gentoo-2-8dd7901736801034f459255820a99e4f1d3c9bfa.zip
remove nptl support #38622
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.2-r9.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r9.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r9.ebuild b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
index 33f88e3659fe..5da6bd3418f3 100644
--- a/sys-libs/glibc/glibc-2.3.2-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.13 2004/01/18 10:16:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.14 2004/01/20 00:48:02 vapier Exp $
-IUSE="nls pic build nptl"
+IUSE="nls pic build"
inherit eutils flag-o-matic gcc
@@ -62,7 +62,6 @@ LICENSE="LGPL-2"
# We need new cleanup attribute support from gcc for NPTL among things ...
DEPEND=">=sys-devel/gcc-3.2.3-r1
- !ppc? ( nptl? ( >=sys-devel/gcc-3.3.1-r1 ) )
>=sys-devel/binutils-2.14.90.0.6-r1
hppa? ( >=sys-kernel/hppa-headers-2.4.21_p13 ) : ( virtual/os-headers )
nls? ( sys-devel/gettext )"
@@ -127,6 +126,8 @@ get_KHV() {
}
use_nptl() {
+ return 1
+
# Enable NPTL support if:
# - We have 'nptl' in USE
# - We have linux-2.5 or later kernel (should prob check for 2.4.20 ...)