summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-09 05:38:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-09 05:38:29 +0000
commitaeff5e864d8283aff65f76d324661493fb234d9f (patch)
tree00c8b252d9701ff8acd826f54c8c7e587fd88e27 /sys-libs/db
parentAdd 2.6.25-r6, remove 2.6.24-r3. (diff)
downloadgentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.tar.gz
gentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.tar.bz2
gentoo-2-aeff5e864d8283aff65f76d324661493fb234d9f.zip
Fix bug #235025 for libtool-2.2 and non-bash boxes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5-00283-g70bb089 x86_64)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog7
-rw-r--r--sys-libs/db/db-4.2.52_p5-r1.ebuild10
-rw-r--r--sys-libs/db/db-4.3.29_p1-r1.ebuild10
-rw-r--r--sys-libs/db/db-4.5.20_p2-r1.ebuild10
-rw-r--r--sys-libs/db/db-4.6.21_p3-r1.ebuild10
-rw-r--r--sys-libs/db/db-4.7.25_p1-r1.ebuild10
6 files changed, 46 insertions, 11 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 10d9fbbb3f4f..006bb04635f8 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.262 2008/08/16 23:27:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.263 2008/09/09 05:38:29 robbat2 Exp $
+
+ 09 Sep 2008; Robin H. Johnson <robbat2@gentoo.org> db-4.2.52_p5-r1.ebuild,
+ db-4.3.29_p1-r1.ebuild, db-4.5.20_p2-r1.ebuild, db-4.6.21_p3-r1.ebuild,
+ db-4.7.25_p1-r1.ebuild:
+ Fix bug #235025 for libtool-2.2 and non-bash boxes.
16 Aug 2008; Robin H. Johnson <robbat2@gentoo.org>
+files/db-3.2.9-gcc43.patch, db-3.2.9_p2.ebuild:
diff --git a/sys-libs/db/db-4.2.52_p5-r1.ebuild b/sys-libs/db/db-4.2.52_p5-r1.ebuild
index 152a957c0015..9ebc2f9c0b11 100644
--- a/sys-libs/db/db-4.2.52_p5-r1.ebuild
+++ b/sys-libs/db/db-4.2.52_p5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p5-r1.ebuild,v 1.1 2008/08/16 22:22:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p5-r1.ebuild,v 1.2 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -71,6 +71,12 @@ src_unpack() {
# END of 4.5+earlier specific
cd "${S}"/../dist
rm -f aclocal/libtool.{m4,ac} aclocal.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, missing_sh/ bash, missing_sh/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -133,7 +139,7 @@ src_compile() {
sed -i \
-e 's/-shrext $(SOFLAGS)/-shrext .so $(SOFLAGS)/g' \
Makefile
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {
diff --git a/sys-libs/db/db-4.3.29_p1-r1.ebuild b/sys-libs/db/db-4.3.29_p1-r1.ebuild
index 9d64f2e23f69..47c79bc98705 100644
--- a/sys-libs/db/db-4.3.29_p1-r1.ebuild
+++ b/sys-libs/db/db-4.3.29_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29_p1-r1.ebuild,v 1.3 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29_p1-r1.ebuild,v 1.4 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -72,6 +72,12 @@ src_unpack() {
# END of 4.5+earlier specific
cd "${S}"/../dist
rm -f aclocal/libtool.{m4,ac} aclocal.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, missing_sh/ bash, missing_sh/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -136,7 +142,7 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {
diff --git a/sys-libs/db/db-4.5.20_p2-r1.ebuild b/sys-libs/db/db-4.5.20_p2-r1.ebuild
index 3e6a5cc4844c..aa6d86d7bca6 100644
--- a/sys-libs/db/db-4.5.20_p2-r1.ebuild
+++ b/sys-libs/db/db-4.5.20_p2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.2 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2-r1.ebuild,v 1.3 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -70,6 +70,12 @@ src_unpack() {
# END of 4.5+earlier specific
cd "${S}"/../dist
rm -f aclocal/libtool.{m4,ac} aclocal.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -143,7 +149,7 @@ src_compile() {
sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {
diff --git a/sys-libs/db/db-4.6.21_p3-r1.ebuild b/sys-libs/db/db-4.6.21_p3-r1.ebuild
index 46852ddf2b1b..58ad18d50870 100644
--- a/sys-libs/db/db-4.6.21_p3-r1.ebuild
+++ b/sys-libs/db/db-4.6.21_p3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3-r1.ebuild,v 1.2 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3-r1.ebuild,v 1.3 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -63,6 +63,12 @@ src_unpack() {
if use !bootstrap; then
cd "${S}"/../dist
rm -f aclocal/libtool.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -136,7 +142,7 @@ src_compile() {
sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {
diff --git a/sys-libs/db/db-4.7.25_p1-r1.ebuild b/sys-libs/db/db-4.7.25_p1-r1.ebuild
index 3e54a28c885b..8d66541ed3ca 100644
--- a/sys-libs/db/db-4.7.25_p1-r1.ebuild
+++ b/sys-libs/db/db-4.7.25_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.3 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.7.25_p1-r1.ebuild,v 1.4 2008/09/09 05:38:29 robbat2 Exp $
inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
@@ -63,6 +63,12 @@ src_unpack() {
if use !bootstrap; then
cd "${S}"/../dist
rm -f aclocal/libtool.m4
+ sed -i \
+ -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
+ configure.ac
+ sed -i \
+ -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
+ aclocal/programs.m4
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -136,7 +142,7 @@ src_compile() {
sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
&& mv Makefile.cpy Makefile
- emake -j1 || die "make failed"
+ emake || die "make failed"
}
src_install() {