summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-08 23:43:38 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-08 23:43:38 +0000
commitbbb178ad4669f52dad39c480f4ae0733674ecd44 (patch)
tree48518b97c0e6264393f197ba8d18a709fb87a9e7 /sys-libs/db/db-4.1.24.ebuild
parentadded new berkley DB per Seemant's request (diff)
downloadgentoo-2-bbb178ad4669f52dad39c480f4ae0733674ecd44.tar.gz
gentoo-2-bbb178ad4669f52dad39c480f4ae0733674ecd44.tar.bz2
gentoo-2-bbb178ad4669f52dad39c480f4ae0733674ecd44.zip
added new berkley DB per Seemant's request... masked
Diffstat (limited to 'sys-libs/db/db-4.1.24.ebuild')
-rw-r--r--sys-libs/db/db-4.1.24.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
new file mode 100644
index 000000000000..1e8fc0642482
--- /dev/null
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.1 2002/10/08 23:43:38 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Berkeley DB"
+
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4"
+LICENSE="DB"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cd dist
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install () {
+ cd dist
+
+ make prefix=${D}/usr install || die
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+}