summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-28 14:58:23 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-28 14:58:23 +0000
commitdf2387609b55140a3eb8bc7098b32034ab6b9d33 (patch)
tree3c727af5b84e40f8d098e72cb897df8caa84e798 /sys-kernel
parentadded speedimproving patch (diff)
downloadgentoo-2-df2387609b55140a3eb8bc7098b32034ab6b9d33.tar.gz
gentoo-2-df2387609b55140a3eb8bc7098b32034ab6b9d33.tar.bz2
gentoo-2-df2387609b55140a3eb8bc7098b32034ab6b9d33.zip
see changelog :)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog15
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre32
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre3.ebuild90
3 files changed, 103 insertions, 4 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 22ae1eeeabb0..24576b258dfb 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,14 +1,21 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.41 2003/02/25 21:08:59 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.42 2003/02/28 14:58:23 lostlogic Exp $
TODO:
* Update NTFS
* Check EVMS version
- * Resolve a bunch of random problems people are having
- this may involve ripping the guts out of the patchset
- and redoing it from a different core (not ck?)
* Keep grabbing hardware stuff from xfs-sources
+ * Look into the new IDE core for this set maybe
+
+*lolo-sources-2.4.20.2_pre3 (28 Feb 2003)
+
+ Changes from _pre2:
+ * Update -ck patches:
+ supermount (having random hangs with supermount? fixed.)
+ aavm
+ * Update some iptables stuff and switch some patches in the iptables
+ * A few other minor changes.
*lolo-sources-2.4.20.2_pre2 (17 Feb 2003)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre3 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre3
new file mode 100644
index 000000000000..84464d893ad3
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre3
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 18f6be4d3de26f8589c9f369dde08f2e patches-2.4.20-lolo-r2_pre3.tar.bz2 2448341
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre3.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre3.ebuild
new file mode 100644
index 000000000000..8e5f08c0fb69
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre3.ebuild,v 1.1 2003/02/28 14:58:23 lostlogic Exp $
+
+IUSE="build crypt xfs"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8[7-9]*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ # This is the non-ratified xfs USE flag, enables XFS which is not
+ # patched by default because it can cause problems with JFS's
+ # journals.
+# if [ -z "`use xfs`" ]; then
+# einfo "No XFS support, is this on purpose?"
+# for file in 79*;do
+# einfo "Dropping ${file}..."
+# rm -f ${file}
+# done
+# else
+# einfo "Enabling XFS patch, are you sure you want this?"
+# fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+# [ `use xfs` ] && ewarn "XFS patches enabled, this may cause JFS problems" || \
+# einfo "XFS not enabled, is that on purpose? JFS users beware of XFS."
+
+}