summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-09-15 22:07:26 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-09-15 22:07:26 +0000
commitdcae030cf27aed0325bfb26cd811a176f72c550e (patch)
tree1c47cc4ffe3d16b1171087b1a810bbbb9ceedecd /sys-kernel
parentEnchance -libpng15.patch by _AxS_ from Freenode with some bits also from NetB... (diff)
downloadgentoo-2-dcae030cf27aed0325bfb26cd811a176f72c550e.tar.gz
gentoo-2-dcae030cf27aed0325bfb26cd811a176f72c550e.tar.bz2
gentoo-2-dcae030cf27aed0325bfb26cd811a176f72c550e.zip
Based on 2.6.32.46 + genpatches-2.6.32-43 + grsecurity-2.2.2-2.6.32.46-201109150655
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r68.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index a3f8fcd2f10a..7ca80d084054 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.470 2011/09/13 18:12:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.471 2011/09/15 22:07:26 blueness Exp $
+
+*hardened-sources-2.6.32-r68 (15 Sep 2011)
+
+ 15 Sep 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r68.ebuild:
+ Based on 2.6.32.46 + genpatches-2.6.32-43 +
+ grsecurity-2.2.2-2.6.32.46-201109150655
13 Sep 2011; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-2.6.32-r64.ebuild, -hardened-sources-2.6.39-r12.ebuild,
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r68.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r68.ebuild
new file mode 100644
index 000000000000..43eaf4087ac3
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r68.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r68.ebuild,v 1.1 2011/09/15 22:07:26 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="43"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-71"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2000_fix-broken-backport-for-ipv6-tunnels.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}