summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2011-10-28 12:38:50 +0000
committerMike Pagano <mpagano@gentoo.org>2011-10-28 12:38:50 +0000
commitd66cfa2e1d48180e48396d656901dece21324888 (patch)
treed2fb6d43ec28b9478fc6355c011eff18d62ed3c4 /sys-kernel
parentVersion bump. Bug #386687 by Thomas Raschbacher. Shoud also fix #364541 by St... (diff)
downloadgentoo-2-d66cfa2e1d48180e48396d656901dece21324888.tar.gz
gentoo-2-d66cfa2e1d48180e48396d656901dece21324888.tar.bz2
gentoo-2-d66cfa2e1d48180e48396d656901dece21324888.zip
Version bump
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-docs/ChangeLog9
-rw-r--r--sys-kernel/linux-docs/linux-docs-3.1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-kernel/linux-docs/ChangeLog b/sys-kernel/linux-docs/ChangeLog
index e6b9fea25f2b..9af5e7aec15f 100644
--- a/sys-kernel/linux-docs/ChangeLog
+++ b/sys-kernel/linux-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/linux-docs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.26 2010/11/21 00:41:23 mpagano Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.27 2011/10/28 12:38:50 mpagano Exp $
+
+*linux-docs-3.1 (28 Oct 2011)
+
+ 28 Oct 2011; Michael Pagano <mpagano@gentoo.org> +linux-docs-3.1.ebuild:
+ Version bump
*linux-docs-2.6.36 (21 Nov 2010)
*linux-docs-2.6.35.2 (21 Nov 2010)
diff --git a/sys-kernel/linux-docs/linux-docs-3.1.ebuild b/sys-kernel/linux-docs/linux-docs-3.1.ebuild
new file mode 100644
index 000000000000..1001d8089ee7
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-3.1.ebuild,v 1.1 2011/10/28 12:38:50 mpagano Exp $
+
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}