summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-05-31 23:27:53 +0000
committerBen de Groot <yngwin@gentoo.org>2015-05-31 23:27:53 +0000
commitc0df1714966285d15d7dff21c0706fb5378efaa2 (patch)
tree1d561703236f89f6da124c7f162c563a6d60f58d /sys-kernel
parentRemove old. (diff)
downloadgentoo-2-c0df1714966285d15d7dff21c0706fb5378efaa2.tar.gz
gentoo-2-c0df1714966285d15d7dff21c0706fb5378efaa2.tar.bz2
gentoo-2-c0df1714966285d15d7dff21c0706fb5378efaa2.zip
Add upstream BFS 462 patches (bug #549788)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog9
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.0.4-r1.ebuild (renamed from sys-kernel/ck-sources/ck-sources-4.0.4.ebuild)9
-rw-r--r--sys-kernel/ck-sources/files/bfs462-rtmn-fix.patch26
-rw-r--r--sys-kernel/ck-sources/files/bfs462-update_inittask.patch30
4 files changed, 69 insertions, 5 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 1d25323c59dc..761409889bbd 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.250 2015/05/24 05:04:29 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.251 2015/05/31 23:27:53 yngwin Exp $
+
+*ck-sources-4.0.4-r1 (31 May 2015)
+
+ 31 May 2015; Ben de Groot <yngwin@gentoo.org> +ck-sources-4.0.4-r1.ebuild,
+ +files/bfs462-rtmn-fix.patch, +files/bfs462-update_inittask.patch,
+ -ck-sources-4.0.4.ebuild:
+ Add upstream BFS 462 patches (bug #549788)
*ck-sources-3.18.14 (24 May 2015)
*ck-sources-3.14.43 (24 May 2015)
diff --git a/sys-kernel/ck-sources/ck-sources-4.0.4.ebuild b/sys-kernel/ck-sources/ck-sources-4.0.4-r1.ebuild
index 90abeb577b8b..d90b7ce4d194 100644
--- a/sys-kernel/ck-sources/ck-sources-4.0.4.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-4.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-4.0.4.ebuild,v 1.1 2015/05/19 12:28:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-4.0.4-r1.ebuild,v 1.1 2015/05/31 23:27:53 yngwin Exp $
EAPI="5"
ETYPE="sources"
@@ -56,15 +56,16 @@ if [ -n "${XTRA_INCP_MIN}" ]; then
done
fi
-#-- CK needs sometimes to patch itself... (3.7/3.13)---------------------------
+#-- CK needs sometimes to patch itself... ---------------------------
CK_INCP_URI=""
CK_INCP_LIST=""
-#-- Local patches needed for the ck-patches to apply smoothly (3.4/3.5) -------
+#-- Local patches needed for the ck-patches to apply smoothly -------
PRE_CK_FIX=""
-POST_CK_FIX=""
+POST_CK_FIX="( ${FILESDIR}/bfs462-rtmn-fix.patch
+ ${FILESDIR}/bfs462-update_inittask.patch )"
#--
diff --git a/sys-kernel/ck-sources/files/bfs462-rtmn-fix.patch b/sys-kernel/ck-sources/files/bfs462-rtmn-fix.patch
new file mode 100644
index 000000000000..c3c77fd6854a
--- /dev/null
+++ b/sys-kernel/ck-sources/files/bfs462-rtmn-fix.patch
@@ -0,0 +1,26 @@
+Fix undefined reference to `register_task_migration_notifier'
+
+-ck
+
+---
+ kernel/sched/bfs.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+Index: linux-4.0.2-ck1/kernel/sched/bfs.c
+===================================================================
+--- linux-4.0.2-ck1.orig/kernel/sched/bfs.c 2015-05-08 09:03:55.730280539 +1000
++++ linux-4.0.2-ck1/kernel/sched/bfs.c 2015-05-08 09:18:42.266015120 +1000
+@@ -976,6 +976,13 @@ static inline void deactivate_task(struc
+ clear_sticky(p);
+ }
+
++static ATOMIC_NOTIFIER_HEAD(task_migration_notifier);
++
++void register_task_migration_notifier(struct notifier_block *n)
++{
++ atomic_notifier_chain_register(&task_migration_notifier, n);
++}
++
+ #ifdef CONFIG_SMP
+ void set_task_cpu(struct task_struct *p, unsigned int cpu)
+ {
diff --git a/sys-kernel/ck-sources/files/bfs462-update_inittask.patch b/sys-kernel/ck-sources/files/bfs462-update_inittask.patch
new file mode 100644
index 000000000000..92321c7d1b59
--- /dev/null
+++ b/sys-kernel/ck-sources/files/bfs462-update_inittask.patch
@@ -0,0 +1,30 @@
+Add missing init task changes.
+
+-ck
+
+---
+ include/linux/init_task.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+Index: linux-4.0.2-ck1/include/linux/init_task.h
+===================================================================
+--- linux-4.0.2-ck1.orig/include/linux/init_task.h 2015-05-08 09:03:54.922287214 +1000
++++ linux-4.0.2-ck1/include/linux/init_task.h 2015-05-08 14:09:52.046246570 +1000
+@@ -200,6 +200,9 @@ extern struct task_group root_task_group
+ .cpus_allowed = CPU_MASK_ALL, \
+ .mm = NULL, \
+ .active_mm = &init_mm, \
++ .restart_block = { \
++ .fn = do_no_restart_syscall, \
++ }, \
+ .run_list = LIST_HEAD_INIT(tsk.run_list), \
+ .time_slice = HZ, \
+ .tasks = LIST_HEAD_INIT(tsk.tasks), \
+@@ -243,6 +246,7 @@ extern struct task_group root_task_group
+ INIT_FTRACE_GRAPH \
+ INIT_TRACE_RECURSION \
+ INIT_TASK_RCU_PREEMPT(tsk) \
++ INIT_KASAN(tsk) \
+ }
+ #else /* CONFIG_SCHED_BFS */
+ #define INIT_TASK_COMM "swapper"