summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-26 23:25:14 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-26 23:25:14 +0000
commitab282ac91f1bf71b7904142fb7c8fff0fe679095 (patch)
tree657ec2429363e67578114291bb34208b94b6e35c /sys-kernel
parentCleanup virtuals, switch in arm-headers for linux-headers (diff)
downloadgentoo-2-ab282ac91f1bf71b7904142fb7c8fff0fe679095.tar.gz
gentoo-2-ab282ac91f1bf71b7904142fb7c8fff0fe679095.tar.bz2
gentoo-2-ab282ac91f1bf71b7904142fb7c8fff0fe679095.zip
add arm sources ebuild
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/arm-sources/ChangeLog9
-rw-r--r--sys-kernel/arm-sources/arm-sources-2.4.19.ebuild91
-rw-r--r--sys-kernel/arm-sources/files/digest-arm-sources-2.4.193
3 files changed, 103 insertions, 0 deletions
diff --git a/sys-kernel/arm-sources/ChangeLog b/sys-kernel/arm-sources/ChangeLog
new file mode 100644
index 000000000000..b1afb0c98e6a
--- /dev/null
+++ b/sys-kernel/arm-sources/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/arm-sources
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-sources/ChangeLog,v 1.1 2003/02/26 23:25:14 zwelch Exp $
+
+*arm-sources-2.4.19 (24 Feb 2003)
+
+ 24 Feb 2003; Zach Welch <zwelch@gentoo.org> arm-sources-2.4.19.ebuild files/digest-arm-sources-2.4.19 :
+ New ebuild for ARM kernel, supports Netwinder only for now
+
diff --git a/sys-kernel/arm-sources/arm-sources-2.4.19.ebuild b/sys-kernel/arm-sources/arm-sources-2.4.19.ebuild
new file mode 100644
index 000000000000..52b62f17fee4
--- /dev/null
+++ b/sys-kernel/arm-sources/arm-sources-2.4.19.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-sources/arm-sources-2.4.19.ebuild,v 1.1 2003/02/26 23:25:14 zwelch Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+IUSE=""
+DEPEND=""
+LICENSE="GPL"
+
+ETYPE="sources"
+inherit kernel
+
+#####
+# move to arm profile
+
+# this specifies the main ARM kernel patch level
+ARM_PATCH_SUFFIX="rmk5"
+
+######
+# move to ${PORTDIR}/subarch.eclass
+# then move to ${PORTDIR}/profiles/profile-arm-1.4/netwinder/subarch.conf
+
+# this specifies the SUBARCH kernel patch level and download location
+# currently, only netwinder supported
+SUBARCH_KERNEL_SUFFIX="-nw1"
+SUBARCH_KERNEL_URLBASE="\
+ http://netwinder.oregonstate.edu/users/r/ralphs/kernel/beta"
+SUBARCH_KERNEL_HOMEPAGE="http://www.netwinder.org/"
+
+#####
+
+# set the kernel version now
+OKV=2.4.19
+EXTRAVERSION="${ARM_PATCH_SUFFIX}${SUBARCH_KERNEL_SUFFIX}"
+KV="${OKV}-${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
+# this is the main rmk ARM Kernel Patch
+ARM_KERNEL_PATCH="patch-${OKV}-${ARM_PATCH_SUFFIX}"
+# this is the kernel patch for SUBARCH
+[ -n "${SUBARCH_KERNEL_SUFFIX}" ] && \
+ SUBARCH_KERNEL_PATCH="${ARM_KERNEL_PATCH}${SUBARCH_KERNEL_SUFFIX}" || \
+ SUBARCH_KERNEL_PATCH=""
+
+# What's in this kernel?
+# INCLUDED:
+# stock 2.4.19 kernel sources
+# rmk patches for armlinux support
+
+DESCRIPTION="Full sources for the ARM/Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 \
+ ftp://ftp.arm.linux.org.uk/pub/armlinux/source/kernel-patches/v2.4/${ARM_KERNEL_PATCH}.bz2"
+
+if [ -n "${SUBARCH_KERNEL_PATCH}" ]; then
+ if [ -n "${SUBARCH_KERNEL_URLBASE}" ]; then
+ SRC_URI="${SRC_URI} \
+ ${SUBARCH_KERNEL_URLBASE}/${SUBARCH_KERNEL_PATCH}.gz"
+ else
+ die "${SUBARCH}: ${SUBARCH_KERNEL_PATCH} does not have a URLBASE"
+ fi
+fi
+
+HOMEPAGE="${SUBARCH_KERNEL_HOMEPAGE} http://www.arm.linux.org.uk/ \
+ http://www.kernel.org/ http://www.gentoo.org/"
+KEYWORDS="arm -hppa -x86 -ppc -sparc -alpha -mips"
+SLOT="${KV}"
+
+src_unpack() {
+ # base vanilla source
+ unpack "linux-${OKV}.tar.bz2" || die
+ mv "${WORKDIR}/linux-${OKV}" "${WORKDIR}/linux-${KV}"
+
+ # plus the Russell M. King kernel patches
+ unpack "${ARM_KERNEL_PATCH}.bz2" || die
+
+ # plus an optional SUBARCH kernel patch
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { unpack "${SUBARCH_KERNEL_PATCH}.gz" || die; }
+
+ # do the actual patching
+ cd ${S} || die
+ einfo "Applying ${ARM_KERNEL_PATCH}"
+ patch -p1 < "${WORKDIR}/${ARM_KERNEL_PATCH}" || die
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { einfo "Applying ${ARM_KERNEL_PATCH}" && \
+ patch -p1 < "${WORKDIR}/${SUBARCH_KERNEL_PATCH}" || die; }
+
+ kernel_universal_unpack
+}
+
diff --git a/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19 b/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19
new file mode 100644
index 000000000000..edabec08f66d
--- /dev/null
+++ b/sys-kernel/arm-sources/files/digest-arm-sources-2.4.19
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 075edc3045f38eb3a4fe24efaa5a4242 patch-2.4.19-rmk5.bz2 622014
+MD5 68d350dbabf44d7ff2042df79807cc0c patch-2.4.19-rmk5-nw1.gz 148995