summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-09-01 18:52:45 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-09-01 18:52:45 +0000
commit95724786cf148538ca04378791beff9733a03523 (patch)
treed937cab98bbadf9cbec308d52806d5ec1b53c925 /sys-kernel
parentVersion bump. (diff)
downloadgentoo-2-95724786cf148538ca04378791beff9733a03523.tar.gz
gentoo-2-95724786cf148538ca04378791beff9733a03523.tar.bz2
gentoo-2-95724786cf148538ca04378791beff9733a03523.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog7
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.0.4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index e19c41dbb5a7..41dc3ed90365 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.198 2011/07/30 17:00:44 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.199 2011/09/01 18:52:45 nelchael Exp $
+
+*ck-sources-3.0.4 (01 Sep 2011)
+
+ 01 Sep 2011; Krzysztof Pawlik <nelchael@gentoo.org> +ck-sources-3.0.4.ebuild:
+ Version bump.
*ck-sources-2.6.39-r2 (30 Jul 2011)
diff --git a/sys-kernel/ck-sources/ck-sources-3.0.4.ebuild b/sys-kernel/ck-sources/ck-sources-3.0.4.ebuild
new file mode 100644
index 000000000000..a2b021de5b5b
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.0.4.ebuild,v 1.1 2011/09/01 18:52:45 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="5"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+BASE_VERSION="$(get_version_component_range 1-2).0"
+CK_VERSION="1"
+
+CK_URI="mirror://kernel/linux/kernel/people/ck/patches/3.0/${BASE_VERSION}-ck${CK_VERSION}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}