summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-31 22:33:59 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-31 22:33:59 +0000
commit869bdc377c1f31554059c08d8aa0f944160ffa57 (patch)
tree7fd5d4e8c7f1fa63761e80b57dfbdcc5916efeaf /sys-kernel
parentFixed pserver non-anonymous logins (diff)
downloadgentoo-2-869bdc377c1f31554059c08d8aa0f944160ffa57.tar.gz
gentoo-2-869bdc377c1f31554059c08d8aa0f944160ffa57.tar.bz2
gentoo-2-869bdc377c1f31554059c08d8aa0f944160ffa57.zip
woohoo I've decided to go _rc :)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog15
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_rc12
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_rc1.ebuild55
3 files changed, 69 insertions, 3 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index ec000929444b..a3a9d718aa6f 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,16 +1,25 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.30 2002/12/30 23:27:52 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.31 2002/12/31 22:33:59 lostlogic Exp $
TODO before gentoo-sources-2.4.20-r1:
* Documentation
* Make sure hardware support is synched with xfs-sources
* Test away
- * Possibly switch encrypted loopback patches?
- * Possibly make the elevator.c changes a configurable option
* Possibly KT400 pci.ids
* Whatever else I'm forgetting
+*lolo-sources-2.4.20.1_rc1 (2002)
+ Well we've finally made it to an _rc kernel here... at this point
+ it is bug fixes and tiny hardware modules ONLY
+
+ Changes from _pre9:
+ * Drop the elevator.c change, it makes things worse in many situations
+ * Add support for the ECC driver
+ * Add TIOCGDEV support back in
+ * Add xfs+quota-v2+kdb support
+ * Fix 2 users of current->nice !works
+
*lolo-sources-2.4.20.1_pre9 (30 Dec 2002)
30 Dec 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre9.ebuild :
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_rc1 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_rc1
new file mode 100644
index 000000000000..991acced2c19
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_rc1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 db7d34c0e6a9ffda7f06e11f27303d72 patches-2.4.20-lolo-r1_rc1.tar.bz2 2770220
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_rc1.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_rc1.ebuild
new file mode 100644
index 000000000000..59345f323d4a
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_rc1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_rc1.ebuild,v 1.1 2002/12/31 22:33:59 lostlogic Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a very beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+
+}