summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-09-07 09:53:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-09-07 09:53:00 +0000
commit81d8b0ab77232c15792cc0b6ac612689250047b6 (patch)
tree11b9334911bb04316d8a919e2ef1faaa9a114dce /sys-kernel
parentVersion bump (diff)
downloadgentoo-2-81d8b0ab77232c15792cc0b6ac612689250047b6.tar.gz
gentoo-2-81d8b0ab77232c15792cc0b6ac612689250047b6.tar.bz2
gentoo-2-81d8b0ab77232c15792cc0b6ac612689250047b6.zip
Version bumps
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog12
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r16.ebuild46
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.34-r4.ebuild46
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index e70503b398c4..b083eeab3016 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.335 2010/09/02 23:05:45 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.336 2010/09/07 09:53:00 blueness Exp $
+
+*hardened-sources-2.6.34-r4 (07 Sep 2010)
+*hardened-sources-2.6.32-r16 (07 Sep 2010)
+
+ 07 Sep 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r16.ebuild, +hardened-sources-2.6.34-r4.ebuild:
+ hardened-sources-2.6.32-r16 based on 2.6.32.21 +
+ grsec-2.2.0-2.6.32.21-201009032133
+ hardened-sources-2.6.34-r4 based on 2.6.34.6 +
+ grsec-2.2.0-2.6.34.6-201009041352
02 Sep 2010; Anthony G. Basile <blueness@gentoo.org> ChangeLog:
hardened-sources-2.6.32-r15 based on 2.6.32.21 +
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r16.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r16.ebuild
new file mode 100644
index 000000000000..3d92159e52c3
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r16.ebuild,v 1.1 2010/09/07 09:53:00 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="19"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-19"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.34-r4.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.34-r4.ebuild
new file mode 100644
index 000000000000..5df508c1bcfb
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.34-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.34-r4.ebuild,v 1.1 2010/09/07 09:53:00 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-5"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}