summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-30 11:32:46 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-30 11:32:46 +0000
commit5c930819d614d6f9edef4d82916fdf12d16e0720 (patch)
treeaf6d4673946b5a9725064f97b477d0e8c35a8f77 /sys-kernel
parentamd64/x86 stable, bug #290112 (diff)
downloadgentoo-2-5c930819d614d6f9edef4d82916fdf12d16e0720.tar.gz
gentoo-2-5c930819d614d6f9edef4d82916fdf12d16e0720.tar.bz2
gentoo-2-5c930819d614d6f9edef4d82916fdf12d16e0720.zip
modified versioning scheme to allow revisions of the same patchset. the patchset version is now defined by _p. this was necessary in order to be able to add hotfixes (like the one in 2.6.31_p5-r1).
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/zen-sources/ChangeLog15
-rw-r--r--sys-kernel/zen-sources/files/zen-sources-2.6.31_p5-config_fb_fix.patch12
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.30_p9.ebuild (renamed from sys-kernel/zen-sources/zen-sources-2.6.30-r9.ebuild)10
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.31_p4.ebuild (renamed from sys-kernel/zen-sources/zen-sources-2.6.31-r4.ebuild)10
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.31_p5-r1.ebuild (renamed from sys-kernel/zen-sources/zen-sources-2.6.31-r5.ebuild)11
5 files changed, 51 insertions, 7 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index f7db3b7d4b70..4b3fbc169e16 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.2 2009/10/29 07:35:41 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.3 2009/10/30 11:32:45 wired Exp $
+
+*zen-sources-2.6.31_p5-r1 (30 Oct 2009)
+*zen-sources-2.6.31_p4 (30 Oct 2009)
+*zen-sources-2.6.30_p9 (30 Oct 2009)
+
+ 30 Oct 2009; Alex Alexander <wired@gentoo.org>
+ -zen-sources-2.6.30-r9.ebuild, +zen-sources-2.6.30_p9.ebuild,
+ -zen-sources-2.6.31-r4.ebuild, -zen-sources-2.6.31-r5.ebuild,
+ +zen-sources-2.6.31_p4.ebuild, +zen-sources-2.6.31_p5-r1.ebuild,
+ +files/zen-sources-2.6.31_p5-config_fb_fix.patch:
+ modified versioning scheme to allow revisions of the same patchset. the
+ patchset version is now defined by _p. this was necessary in order to be
+ able to add hotfixes (like the one in 2.6.31_p5-r1).
*zen-sources-2.6.31-r5 (29 Oct 2009)
diff --git a/sys-kernel/zen-sources/files/zen-sources-2.6.31_p5-config_fb_fix.patch b/sys-kernel/zen-sources/files/zen-sources-2.6.31_p5-config_fb_fix.patch
new file mode 100644
index 000000000000..276c48efd17a
--- /dev/null
+++ b/sys-kernel/zen-sources/files/zen-sources-2.6.31_p5-config_fb_fix.patch
@@ -0,0 +1,12 @@
+diff --git a/drivers/video/console/fbcon.c b/drivers/video/console/fbcon.c
+index 70316a8..3d0ccc0 100644
+--- a/drivers/video/console/fbcon.c
++++ b/drivers/video/console/fbcon.c
+@@ -204,6 +204,7 @@ int fbcon_is_softback(const unsigned short *str)
+ return 1;
+ return 0;
+ }
++EXPORT_SYMBOL(fbcon_is_softback);
+
+ #ifdef CONFIG_FRAMEBUFFER_CONSOLE_ROTATION
+ static inline void fbcon_set_rotation(struct fb_info *info)
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.30-r9.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.30_p9.ebuild
index 21599bdccd5f..51fba5c891b7 100644
--- a/sys-kernel/zen-sources/zen-sources-2.6.30-r9.ebuild
+++ b/sys-kernel/zen-sources/zen-sources-2.6.30_p9.ebuild
@@ -9,6 +9,7 @@ K_SECURITY_UNSUPPORTED="1"
RESTRICT="binchecks strip primaryuri mirror"
+CKV="${PV/_p[0-9]*}"
ETYPE="sources"
inherit kernel-2
detect_version
@@ -16,7 +17,12 @@ K_NOSETEXTRAVERSION="don't_set_it"
DESCRIPTION="The Zen Kernel v${KV_MAJOR}.${KV_MINOR}-${PR}"
HOMEPAGE="http://zen-kernel.org"
-ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${KV_FULL}.patch${COMPRESSTYPE}"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
SRC_URI="${KERNEL_URI} ${ZEN_URI}"
KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
@@ -36,7 +42,7 @@ pkg_setup(){
src_unpack(){
kernel-2_src_unpack
cd "${S}"
- epatch "${DISTDIR}"/${KV_FULL}.patch${COMPRESSTYPE}
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
}
K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.31-r4.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.31_p4.ebuild
index 21599bdccd5f..51fba5c891b7 100644
--- a/sys-kernel/zen-sources/zen-sources-2.6.31-r4.ebuild
+++ b/sys-kernel/zen-sources/zen-sources-2.6.31_p4.ebuild
@@ -9,6 +9,7 @@ K_SECURITY_UNSUPPORTED="1"
RESTRICT="binchecks strip primaryuri mirror"
+CKV="${PV/_p[0-9]*}"
ETYPE="sources"
inherit kernel-2
detect_version
@@ -16,7 +17,12 @@ K_NOSETEXTRAVERSION="don't_set_it"
DESCRIPTION="The Zen Kernel v${KV_MAJOR}.${KV_MINOR}-${PR}"
HOMEPAGE="http://zen-kernel.org"
-ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${KV_FULL}.patch${COMPRESSTYPE}"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
SRC_URI="${KERNEL_URI} ${ZEN_URI}"
KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
@@ -36,7 +42,7 @@ pkg_setup(){
src_unpack(){
kernel-2_src_unpack
cd "${S}"
- epatch "${DISTDIR}"/${KV_FULL}.patch${COMPRESSTYPE}
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
}
K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.31-r5.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.31_p5-r1.ebuild
index 8cd675b96f1b..9043c5bd0e76 100644
--- a/sys-kernel/zen-sources/zen-sources-2.6.31-r5.ebuild
+++ b/sys-kernel/zen-sources/zen-sources-2.6.31_p5-r1.ebuild
@@ -9,6 +9,7 @@ K_SECURITY_UNSUPPORTED="1"
RESTRICT="binchecks strip primaryuri mirror"
+CKV="${PV/_p[0-9]*}"
ETYPE="sources"
inherit kernel-2
detect_version
@@ -16,7 +17,12 @@ K_NOSETEXTRAVERSION="don't_set_it"
DESCRIPTION="The Zen Kernel v${KV_MAJOR}.${KV_MINOR}-${PR}"
HOMEPAGE="http://zen-kernel.org"
-ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${KV_FULL}.patch${COMPRESSTYPE}"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
SRC_URI="${KERNEL_URI} ${ZEN_URI}"
KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
@@ -36,7 +42,8 @@ pkg_setup(){
src_unpack(){
kernel-2_src_unpack
cd "${S}"
- epatch "${DISTDIR}"/${KV_FULL}.patch${COMPRESSTYPE}
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+ epatch "${FILESDIR}"/"${P}-config_fb_fix.patch"
}
K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \