summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-10-15 15:29:16 +0000
committerMike Pagano <mpagano@gentoo.org>2012-10-15 15:29:16 +0000
commit5c513b15c350a4d7a671dd951d5c7b2609d81233 (patch)
tree2bd26f9b9e9a9fd0a203b0916ca87c3b48c75a66 /sys-kernel
parentEnable EAPI 5 support. (diff)
downloadgentoo-2-5c513b15c350a4d7a671dd951d5c7b2609d81233.tar.gz
gentoo-2-5c513b15c350a4d7a671dd951d5c7b2609d81233.tar.bz2
gentoo-2-5c513b15c350a4d7a671dd951d5c7b2609d81233.zip
Version bump
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/ChangeLog7
-rw-r--r--sys-kernel/git-sources/git-sources-3.7_rc1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index a0c816841ff8..7843e68955a6 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1313 2012/09/24 15:56:48 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1314 2012/10/15 15:29:16 mpagano Exp $
+
+*git-sources-3.7_rc1 (15 Oct 2012)
+
+ 15 Oct 2012; Michael Pagano <mpagano@gentoo.org> +git-sources-3.7_rc1.ebuild:
+ Version bump
*git-sources-3.6_rc7 (24 Sep 2012)
diff --git a/sys-kernel/git-sources/git-sources-3.7_rc1.ebuild b/sys-kernel/git-sources/git-sources-3.7_rc1.ebuild
new file mode 100644
index 000000000000..5bae0d8c2588
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.7_rc1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.7_rc1.ebuild,v 1.1 2012/10/15 15:29:16 mpagano Exp $
+
+EAPI="4"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}