summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-07 08:04:49 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-07 08:04:49 +0000
commit56a821792bb73e418c4cce26659ed6bec306813c (patch)
tree7115c4940f5b77db65e0818903c8fb90950ba27e /sys-kernel
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-56a821792bb73e418c4cce26659ed6bec306813c.tar.gz
gentoo-2-56a821792bb73e418c4cce26659ed6bec306813c.tar.bz2
gentoo-2-56a821792bb73e418c4cce26659ed6bec306813c.zip
Bump to latest genpatches and linux release
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/aufs-sources/ChangeLog9
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-3.14.44.ebuild85
-rw-r--r--sys-kernel/aufs-sources/aufs-sources-4.0.5.ebuild85
-rw-r--r--sys-kernel/aufs-sources/metadata.xml24
4 files changed, 190 insertions, 13 deletions
diff --git a/sys-kernel/aufs-sources/ChangeLog b/sys-kernel/aufs-sources/ChangeLog
index af482c43047b..6073fe567487 100644
--- a/sys-kernel/aufs-sources/ChangeLog
+++ b/sys-kernel/aufs-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/aufs-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.191 2015/05/23 06:19:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/ChangeLog,v 1.192 2015/06/07 08:04:49 jlec Exp $
+
+*aufs-sources-3.14.44 (07 Jun 2015)
+*aufs-sources-4.0.5 (07 Jun 2015)
+
+ 07 Jun 2015; Justin Lecher <jlec@gentoo.org> +aufs-sources-3.14.44.ebuild,
+ +aufs-sources-4.0.5.ebuild, metadata.xml:
+ Bump to latest genpatches and linux release
*aufs-sources-3.14.43 (23 May 2015)
*aufs-sources-3.18.14 (23 May 2015)
diff --git a/sys-kernel/aufs-sources/aufs-sources-3.14.44.ebuild b/sys-kernel/aufs-sources/aufs-sources-3.14.44.ebuild
new file mode 100644
index 000000000000..2c763f45432b
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-3.14.44.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-3.14.44.ebuild,v 1.1 2015/06/07 08:04:49 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="50"
+K_DEBLOB_AVAILABLE="1"
+UNIPATCH_STRICTORDER=1
+inherit kernel-2 eutils readme.gentoo
+detect_version
+detect_arch
+
+AUFS_VERSION=3.14.40+_p20150518
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs3-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs3 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND="=sys-fs/aufs-util-3*"
+
+README_GENTOO_SUFFIX="-r1"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs3-kbuild.patch
+ "${WORKDIR}"/aufs3-base.patch
+ "${WORKDIR}"/aufs3-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs3-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ einfo "Using aufs3 version: ${AUFS_VERSION}"
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+src_install() {
+ kernel-2_src_install
+ dodoc "${WORKDIR}"/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
+ docompress -x /usr/share/doc/${PF}/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util || \
+ elog "In order to use aufs FS you need to install sys-fs/aufs-util"
+
+ readme.gentoo_pkg_postinst
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/aufs-sources-4.0.5.ebuild b/sys-kernel/aufs-sources/aufs-sources-4.0.5.ebuild
new file mode 100644
index 000000000000..b6b08eae87b3
--- /dev/null
+++ b/sys-kernel/aufs-sources/aufs-sources-4.0.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aufs-sources/aufs-sources-4.0.5.ebuild,v 1.1 2015/06/07 08:04:49 jlec Exp $
+
+EAPI=5
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="7"
+K_DEBLOB_AVAILABLE="1"
+UNIPATCH_STRICTORDER=1
+inherit kernel-2 eutils readme.gentoo
+detect_version
+detect_arch
+
+AUFS_VERSION=4.0_p20150518
+AUFS_TARBALL="aufs-sources-${AUFS_VERSION}.tar.xz"
+# git archive -v --remote=git://git.code.sf.net/p/aufs/aufs4-standalone aufs${AUFS_VERSION/_p*} > aufs-sources-${AUFS_VERSION}.tar
+AUFS_URI="http://dev.gentoo.org/~jlec/distfiles/${AUFS_TARBALL}"
+
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches http://aufs.sourceforge.net/"
+IUSE="deblob experimental module vanilla"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and aufs4 support"
+SRC_URI="
+ ${KERNEL_URI}
+ ${ARCH_URI}
+ ${AUFS_URI}
+ !vanilla? ( ${GENPATCHES_URI} )
+ "
+
+PDEPEND="=sys-fs/aufs-util-4*"
+
+README_GENTOO_SUFFIX="-r1"
+
+src_unpack() {
+ if use vanilla; then
+ unset UNIPATCH_LIST_GENPATCHES UNIPATCH_LIST_DEFAULT
+ ewarn "You are using USE=vanilla"
+ ewarn "This will drop all support from the gentoo kernel security team"
+ fi
+
+ UNIPATCH_LIST="
+ "${WORKDIR}"/aufs4-kbuild.patch
+ "${WORKDIR}"/aufs4-base.patch
+ "${WORKDIR}"/aufs4-mmap.patch"
+
+ use module && UNIPATCH_LIST+=" "${WORKDIR}"/aufs4-standalone.patch"
+
+ unpack ${AUFS_TARBALL}
+
+ einfo "Using aufs4 version: ${AUFS_VERSION}"
+
+ kernel-2_src_unpack
+}
+
+src_prepare() {
+ if ! use module; then
+ sed -e 's:tristate:bool:g' -i "${WORKDIR}"/fs/aufs/Kconfig || die
+ fi
+ cp -f "${WORKDIR}"/include/uapi/linux/aufs_type.h include/uapi/linux/aufs_type.h || die
+ cp -rf "${WORKDIR}"/{Documentation,fs} . || die
+}
+
+src_install() {
+ kernel-2_src_install
+ dodoc "${WORKDIR}"/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+ docompress -x /usr/share/doc/${PF}/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ has_version sys-fs/aufs-util || \
+ elog "In order to use aufs FS you need to install sys-fs/aufs-util"
+
+ readme.gentoo_pkg_postinst
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/aufs-sources/metadata.xml b/sys-kernel/aufs-sources/metadata.xml
index cabaa65567c1..7c66d9ad6d55 100644
--- a/sys-kernel/aufs-sources/metadata.xml
+++ b/sys-kernel/aufs-sources/metadata.xml
@@ -1,28 +1,28 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="deblob">
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="deblob">
Remove binary blobs from kernel sources to provide libre license
compliance.
</flag>
- <flag name="experimental">
+ <flag name="experimental">
Apply experimental patches; for more information,
see "https://wiki.gentoo.org/wiki/Project:Kernel/Experimental".
</flag>
- <flag name="module">
+ <flag name="module">
Patch kernel to allow aufs being build as a module.
</flag>
- <flag name="vanilla">
+ <flag name="vanilla">
Use vanilla kernel sources without applying genpatches.
WARNING: This flag will drop all support from the Gentoo Kernel
Security team
</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>
- </upstream>
+ </use>
+ <upstream>
+ <remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>
+ </upstream>
</pkgmetadata>