summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-02-12 20:23:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-02-12 20:23:03 +0000
commit2e2c6400e4555ed4b355ec820909fc8e0a402256 (patch)
treee2a18a1d0cde487145a8204a852c1246345f3819 /sys-kernel
parentinitial import (diff)
downloadgentoo-2-2e2c6400e4555ed4b355ec820909fc8e0a402256.tar.gz
gentoo-2-2e2c6400e4555ed4b355ec820909fc8e0a402256.tar.bz2
gentoo-2-2e2c6400e4555ed4b355ec820909fc8e0a402256.zip
sparc header fix sent by me upstream abouta month ago.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch37
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.10.ebuild5
2 files changed, 40 insertions, 2 deletions
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch
index 55d81fd2263d..f4bd448f5a00 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch
@@ -2212,3 +2212,40 @@ diff -urp linux-2.6.10/include/linux/if_fddi.h linux-2.6.10-gentoo/include/linux
/*
* Define max and min legal sizes. The frame sizes do not include
* 4 byte FCS/CRC (frame check sequence).
+--- linux-2.6.10/include/asm-sparc/processor.h 2004-12-11 15:49:24.522603912 -0800
++++ linux-2.6.10-gentoo/include/asm-sparc/processor.h 2004-12-11 15:49:18.865463928 -0800
+@@ -44,11 +44,13 @@
+ struct task_struct;
+
+ #ifdef __KERNEL__
+-struct fpq {
++#define __fpq fpq
++#endif
++
++struct __fpq {
+ unsigned long *insn_addr;
+ unsigned long insn;
+ };
+-#endif
+
+ typedef struct {
+ int seg;
+@@ -67,13 +69,17 @@ struct thread_struct {
+ unsigned long float_regs[32] __attribute__ ((aligned (8)));
+ unsigned long fsr;
+ unsigned long fpqdepth;
+- struct fpq fpqueue[16];
++ struct __fpq fpqueue[16];
+ unsigned long flags;
+ mm_segment_t current_ds;
+ struct exec core_exec; /* just what it says. */
+ int new_signal;
+ };
+
++#ifdef __KERNEL__
++#undef __fpq
++#endif
++
+ #define SPARC_FLAG_KTHREAD 0x1 /* task is a kernel thread */
+ #define SPARC_FLAG_UNALIGNED 0x2 /* is allowed to do unaligned accesses */
+
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild
index f85f99431cfa..64bd114001b6 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild,v 1.1 2005/02/08 22:34:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild,v 1.2 2005/02/12 20:23:03 eradicator Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86"
@@ -8,7 +8,7 @@ inherit kernel-2
detect_version
SRC_URI="${KERNEL_URI}"
-KEYWORDS="-*" # Untested, by using this you are agreeing to file bugs to plasmaroo, aren't you? :-)
+KEYWORDS="-* ~amd64 ~sparc ~x86" # Untested, by using this you are agreeing to file bugs to plasmaroo, aren't you? :-)
UNIPATCH_LIST="
${FILESDIR}/${PN}-2.6.0-sysctl_h-compat.patch
@@ -20,6 +20,7 @@ UNIPATCH_LIST="
${FILESDIR}/${PN}-2.6.8.1-parisc-syscall.patch"
src_unpack() {
+ tc-arch-kernel
kernel-2_src_unpack
# Fixes ... all the mv magic is to keep sed from dumping