summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-05 18:54:26 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-05 18:54:26 +0000
commit96b86ea3a4977be69defab6a4bc68f46aef1778e (patch)
treefbe064732b2d8a12f287ab928e73b6f7e03b0106 /sys-kernel/win4lin-sources
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-96b86ea3a4977be69defab6a4bc68f46aef1778e.tar.gz
gentoo-2-96b86ea3a4977be69defab6a4bc68f46aef1778e.tar.bz2
gentoo-2-96b86ea3a4977be69defab6a4bc68f46aef1778e.zip
Added a fix for bug #58008 to the 2.6 ebuild.
Diffstat (limited to 'sys-kernel/win4lin-sources')
-rw-r--r--sys-kernel/win4lin-sources/ChangeLog5
-rw-r--r--sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-kernel/win4lin-sources/ChangeLog b/sys-kernel/win4lin-sources/ChangeLog
index e54c9122d5ea..ec9eea80bf96 100644
--- a/sys-kernel/win4lin-sources/ChangeLog
+++ b/sys-kernel/win4lin-sources/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-kernel/win4lin-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/ChangeLog,v 1.31 2004/08/05 12:03:02 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/ChangeLog,v 1.32 2004/08/05 18:54:26 plasmaroo Exp $
+
+ 05 Aug 2004; <plasmaroo@gentoo.org> win4lin-sources-2.6.7-r4.ebuild:
+ Added a fix for bug #58008 to the 2.6 ebuild.
*win4lin-sources-2.6.7-r4 (05 Aug 2004)
diff --git a/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild b/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild
index 761ec8a4a2d8..45853c3e6b5a 100644
--- a/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild
+++ b/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild,v 1.1 2004/08/05 12:03:02 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/win4lin-sources/win4lin-sources-2.6.7-r4.ebuild,v 1.2 2004/08/05 18:54:26 plasmaroo Exp $
ETYPE="sources"
inherit kernel-2
@@ -8,7 +8,6 @@ detect_version
MKI_VERSION='1_3_6'
UNIPATCH_LIST="
- ${DISTDIR}/mki-adapter26_${MKI_VERSION}.patch
${DISTDIR}/Kernel-Win4Lin3-${OKV}.patch
${DISTDIR}/linux-${OKV}-CAN-2004-0415.patch
${FILESDIR}/${PN}.CAN-2004-0497.patch
@@ -30,3 +29,10 @@ K_EXTRAEINFO="If there are issues with this kernel, search http://bugs.gentoo.or
existing bug. Only create a new bug if you have not found one that matches
your issue. It is best to do an advanced search as the initial search has a
very low yield. Please assign your bugs to x86-kernel@gentoo.org."
+
+# Temporary fix for bug #58008
+src_unpack() {
+ kernel-2_src_unpack
+ cd ${S}
+ patch -Np1 -i ${DISTDIR}/mki-adapter26_${MKI_VERSION}.patch > /dev/null 2>&1 || die 'Error: Failed to apply mki-adapter patch!'
+}