summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-08-09 18:09:39 +0000
committerChristian Heim <phreak@gentoo.org>2006-08-09 18:09:39 +0000
commit0e11b1fb102f781e8de987066dac89e275b0bfa9 (patch)
tree561bf9f2ed7910a5ade06dd7aff00bc54d0bdac9 /sys-kernel/vanilla-sources
parentAdd package, closes bug #66980. (diff)
downloadgentoo-2-0e11b1fb102f781e8de987066dac89e275b0bfa9.tar.gz
gentoo-2-0e11b1fb102f781e8de987066dac89e275b0bfa9.tar.bz2
gentoo-2-0e11b1fb102f781e8de987066dac89e275b0bfa9.zip
Revision bump. Fixing a compile issue on alpha (request of wolf31o2).
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sys-kernel/vanilla-sources')
-rw-r--r--sys-kernel/vanilla-sources/ChangeLog9
-rw-r--r--sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.4.32-r13
-rw-r--r--sys-kernel/vanilla-sources/files/vanilla-sources-2.4.32-alpha-pci_iommu.patch41
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.4.32-r1.ebuild14
4 files changed, 66 insertions, 1 deletions
diff --git a/sys-kernel/vanilla-sources/ChangeLog b/sys-kernel/vanilla-sources/ChangeLog
index b275c08cb850..2e9b1e634d22 100644
--- a/sys-kernel/vanilla-sources/ChangeLog
+++ b/sys-kernel/vanilla-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/vanilla-sources
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/ChangeLog,v 1.213 2006/08/08 06:07:12 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/ChangeLog,v 1.214 2006/08/09 18:09:39 phreak Exp $
+
+*vanilla-sources-2.4.32-r1 (09 Aug 2006)
+
+ 09 Aug 2006; Christian Heim <phreak@gentoo.org>
+ +files/vanilla-sources-2.4.32-alpha-pci_iommu.patch,
+ +vanilla-sources-2.4.32-r1.ebuild:
+ Revision bump. Fixing a compile issue on alpha (request of wolf31o2).
*vanilla-sources-2.6.18_rc4 (08 Aug 2006)
diff --git a/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.4.32-r1 b/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.4.32-r1
new file mode 100644
index 000000000000..277996b4438a
--- /dev/null
+++ b/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.4.32-r1
@@ -0,0 +1,3 @@
+MD5 38f4d0830e95a20f4bfed17622d5557c linux-2.4.32.tar.bz2 31132159
+RMD160 63ab1a0b18e690170f60de9da7392416311dc609 linux-2.4.32.tar.bz2 31132159
+SHA256 7dace89c3f0850c3d5c32c38c20b600259c314e8cbec29fe3ee59c2fbbee1759 linux-2.4.32.tar.bz2 31132159
diff --git a/sys-kernel/vanilla-sources/files/vanilla-sources-2.4.32-alpha-pci_iommu.patch b/sys-kernel/vanilla-sources/files/vanilla-sources-2.4.32-alpha-pci_iommu.patch
new file mode 100644
index 000000000000..8d5b14f817af
--- /dev/null
+++ b/sys-kernel/vanilla-sources/files/vanilla-sources-2.4.32-alpha-pci_iommu.patch
@@ -0,0 +1,41 @@
+From: Marcelo Tosatti <marcelo@dmt.cnet>
+Date: Tue, 31 Jan 2006 22:26:40 +0000 (-0600)
+Subject: Alpha: fix recursive inlining failure in pci_iommu.c
+X-Git-Tag: v2.4.33-pre2
+X-Git-Url: http://kernel.org/git/?p=linux/kernel/git/marcelo/linux-2.4.git;a=commitdiff;h=0c283a469515ac2eb468921a73058a892f67a96e
+
+Alpha: fix recursive inlining failure in pci_iommu.c
+
+From: Solar Designer <solar@openwall.com>
+
+2.4.32 fails to build on my Alpha like this:
+
+make[1]: Entering directory
+`/stuff/owl-2006-1/usr/src/linux-2.4.32-ow1/arch/alpha/kernel'
+gcc -D__KERNEL__ -I/stuff/owl-2006-1/usr/src/linux-2.4.32-ow1/include
+-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing
+-fno-common -fomit-frame-pointer -pipe -mno-fp-regs -ffixed-8 -mcpu=pca56
+-Wa,-mev6 -nostdinc -iwithprefix include -DKBUILD_BASENAME=pci_iommu
+-c -o pci_iommu.o pci_iommu.c
+pci_iommu.c: In function `sg_fill':
+pci_iommu.c:510: sorry, unimplemented: inlining failed in call to
+'sg_fill': recursive inlining
+pci_iommu.c:558: sorry, unimplemented: called from here
+make[1]: *** [pci_iommu.o] Error 1
+
+This is with gcc 3.4.5. Simply removing the "inline" from the
+declaration
+of sg_fill() makes it build and work.
+---
+
+--- a/arch/alpha/kernel/pci_iommu.c
++++ b/arch/alpha/kernel/pci_iommu.c
+@@ -503,7 +503,7 @@ sg_classify(struct scatterlist *sg, stru
+ /* Given a scatterlist leader, choose an allocation method and fill
+ in the blanks. */
+
+-static inline int
++static int
+ sg_fill(struct scatterlist *leader, struct scatterlist *end,
+ struct scatterlist *out, struct pci_iommu_arena *arena,
+ dma_addr_t max_dma, int dac_allowed)
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.4.32-r1.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.4.32-r1.ebuild
new file mode 100644
index 000000000000..cfb93c08861a
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-2.4.32-r1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.32-r1.ebuild,v 1.1 2006/08/09 18:09:39 phreak Exp $
+
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+UNIPATCH_LIST="${FILESDIR}/vanilla-sources-2.4.32-alpha-pci_iommu.patch"