summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-12-16 15:29:54 +0000
committerChristian Birchinger <joker@gentoo.org>2004-12-16 15:29:54 +0000
commit2e4010f6d914961ce6f67f4d0077d70014204729 (patch)
tree75d1c043a952f512c91e8551e10cddd2f3fb8fe9 /sys-kernel/sparc-sources
parentMarked ppc stable. (Manifest recommit) (diff)
downloadgentoo-2-2e4010f6d914961ce6f67f4d0077d70014204729.tar.gz
gentoo-2-2e4010f6d914961ce6f67f4d0077d70014204729.tar.bz2
gentoo-2-2e4010f6d914961ce6f67f4d0077d70014204729.zip
Updated to squashfs to 2.1. Added security fixes for CAN-2004-1016 and CAN-2004-1137
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog9
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r22
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.28-r2.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 2da9e91ecfee..afdc69a22636 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.70 2004/12/03 02:11:12 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.71 2004/12/16 15:29:54 joker Exp $
+
+*sparc-sources-2.4.28-r2 (15 Dec 2004)
+
+ 15 Dec 2004; Christian Birchinger <joker@gentoo.org>
+ +sparc-sources-2.4.28-r2.ebuild:
+ Updated squashfs to 2.1. Added security fixes for CAN-2004-1016 and
+ CAN-2004-1137
02 Dec 2004; Christian Birchinger <joker@gentoo.org> :
Security fix for CAN-2004-1074 (Bug #72452).
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r2 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r2
new file mode 100644
index 000000000000..793d42303c26
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28-r2
@@ -0,0 +1,2 @@
+MD5 ac7735000d185bc7778c08288760a8a3 linux-2.4.28.tar.bz2 31064046
+MD5 05e09ac56cf3f1f8133dd1ed69909819 patches-2.4.28-sparc-r2.tar.bz2 181346
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.28-r2.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r2.ebuild
new file mode 100644
index 000000000000..1158f91e8da3
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.28-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.28-r2.ebuild,v 1.1 2004/12/16 15:29:54 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel eutils
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+PATCH_VERSION="${KV}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PATCH_VERSION}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${PATCH_VERSION} || die "Unable to cd into ${PATCH_VERSION}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}