summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2011-08-17 15:06:25 +0000
committerStratos Psomadakis <psomas@gentoo.org>2011-08-17 15:06:25 +0000
commit2fe7b89f868362ffd995bd3a15c6b81d3abbf9ed (patch)
tree5dde928d60edd884cdc91773f04cdcfe45a0b4b4 /sys-kernel/rt-sources
parentStable on amd64 wrt bug #369065 (diff)
downloadgentoo-2-2fe7b89f868362ffd995bd3a15c6b81d3abbf9ed.tar.gz
gentoo-2-2fe7b89f868362ffd995bd3a15c6b81d3abbf9ed.tar.bz2
gentoo-2-2fe7b89f868362ffd995bd3a15c6b81d3abbf9ed.zip
New package and ebuild for the real-time kernel patchset
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/ChangeLog10
-rw-r--r--sys-kernel/rt-sources/metadata.xml13
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.0.1_p11.ebuild48
3 files changed, 71 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
new file mode 100644
index 000000000000..7b824fcfe090
--- /dev/null
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-kernel/rt-sources
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.1 2011/08/17 15:06:25 psomas Exp $
+
+*rt-sources-3.0.1_p11 (17 Aug 2011)
+
+ 17 Aug 2011; Stratos Psomadakis <psomas@gentoo.org>
+ +rt-sources-3.0.1_p11.ebuild, +metadata.xml:
+ New package and ebuild for the real-time kernel patchset
+
diff --git a/sys-kernel/rt-sources/metadata.xml b/sys-kernel/rt-sources/metadata.xml
new file mode 100644
index 000000000000..f77ae2045fcf
--- /dev/null
+++ b/sys-kernel/rt-sources/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>psoams@gentoo.org</email>
+ <name>Stratos Psomadakis</name>
+ </maintainer>
+ <longdescription>
+ Real-time patchset for the Linux Kernel
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-kernel/rt-sources/rt-sources-3.0.1_p11.ebuild b/sys-kernel/rt-sources/rt-sources-3.0.1_p11.ebuild
new file mode 100644
index 000000000000..e0d67a5887b7
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.0.1_p11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="3"
+K_SECURITY_UNSUPPORTED="yes"
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+RT_PATCHSET="${PV/*_p}"
+RT_KERNEL="${PV/_p[0-9]*}"
+RT_KERNEL="${RT_KERNEL/_/-}"
+RT_FILE="patch-${RT_KERNEL}-rt${RT_PATCHSET}.patch${COMPRESSTYPE}"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${RT_KERNEL}/${RT_FILE}"
+
+DESCRIPTION="Real-time patchset for the Linux Kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${RT_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-rt}"
+EXTRAVERSION="-rt${RT_PATCHSET}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${RT_FILE}"
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."