summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-24 15:05:15 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-24 15:05:15 +0000
commitb2e1a00583a57a9e4ae8f5801e075f9404beef98 (patch)
tree9b1c151da731809889e757d9c5011dbcdd89ba4b /sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild
parentReplace bad copy of proc mem handling patch. Remove kernel with incorrect pri... (diff)
downloadgentoo-2-b2e1a00583a57a9e4ae8f5801e075f9404beef98.tar.gz
gentoo-2-b2e1a00583a57a9e4ae8f5801e075f9404beef98.tar.bz2
gentoo-2-b2e1a00583a57a9e4ae8f5801e075f9404beef98.zip
replaced bad proc-mem-handling-fix with correct one, removed it from 3.0.7 since it wouldn't apply cleanly. -r1 was still vulnerable.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild')
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild b/sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild
new file mode 100644
index 000000000000..a872a8eb24f5
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.0.7-r2.ebuild,v 1.1 2012/01/24 15:05:15 wired Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."