summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-05-03 15:57:31 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-05-03 15:57:31 +0000
commitc30e17c0ac21638f216d3dac1bfc3d0a0dece32c (patch)
tree87fb649b6bcb0d40bb02e0260ca1acb7bd521950 /sys-kernel/linux-firmware
parentVersion bump #414449 by Lars Wendler (Polynomial-C). (diff)
downloadgentoo-2-c30e17c0ac21638f216d3dac1bfc3d0a0dece32c.tar.gz
gentoo-2-c30e17c0ac21638f216d3dac1bfc3d0a0dece32c.tar.bz2
gentoo-2-c30e17c0ac21638f216d3dac1bfc3d0a0dece32c.zip
New snapshot.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/linux-firmware')
-rw-r--r--sys-kernel/linux-firmware/ChangeLog8
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-20120502.ebuild100
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild4
3 files changed, 109 insertions, 3 deletions
diff --git a/sys-kernel/linux-firmware/ChangeLog b/sys-kernel/linux-firmware/ChangeLog
index d0513d82bc26..6dfc0a1e83a2 100644
--- a/sys-kernel/linux-firmware/ChangeLog
+++ b/sys-kernel/linux-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/linux-firmware
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-firmware/ChangeLog,v 1.37 2012/03/24 17:34:07 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-firmware/ChangeLog,v 1.38 2012/05/03 15:57:31 chithanh Exp $
+
+*linux-firmware-20120502 (03 May 2012)
+
+ 03 May 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +linux-firmware-20120502.ebuild, linux-firmware-99999999.ebuild:
+ New snapshot.
24 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
linux-firmware-20120125.ebuild:
diff --git a/sys-kernel/linux-firmware/linux-firmware-20120502.ebuild b/sys-kernel/linux-firmware/linux-firmware-20120502.ebuild
new file mode 100644
index 000000000000..3bb7b429d116
--- /dev/null
+++ b/sys-kernel/linux-firmware/linux-firmware-20120502.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-firmware/linux-firmware-20120502.ebuild,v 1.1 2012/05/03 15:57:31 chithanh Exp $
+
+EAPI=4
+inherit savedconfig
+
+if [[ ${PV} == 99999999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+fi
+
+DESCRIPTION="Linux firmware files"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BSD freedist"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="savedconfig"
+
+DEPEND=""
+RDEPEND="!savedconfig? (
+ !media-sound/alsa-firmware[alsa_cards_korg1212]
+ !media-sound/alsa-firmware[alsa_cards_maestro3]
+ !media-sound/alsa-firmware[alsa_cards_sb16]
+ !media-sound/alsa-firmware[alsa_cards_ymfpci]
+ !media-tv/cx18-firmware
+ !media-tv/ivtv-firmware
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
+ !net-dialup/ueagle-atm
+ !net-dialup/ueagle4-atm
+ !net-wireless/ar9271-firmware
+ !net-wireless/i2400m-fw
+ !net-wireless/iwl1000-ucode
+ !net-wireless/iwl3945-ucode
+ !net-wireless/iwl4965-ucode
+ !net-wireless/iwl5000-ucode
+ !net-wireless/iwl5150-ucode
+ !net-wireless/iwl6000-ucode
+ !net-wireless/iwl6005-ucode
+ !net-wireless/iwl6030-ucode
+ !net-wireless/iwl6050-ucode
+ !net-wireless/libertas-firmware
+ !net-wireless/rt61-firmware
+ !net-wireless/rt73-firmware
+ !net-wireless/rt2860-firmware
+ !net-wireless/rt2870-firmware
+ !sys-block/qla-fc-firmware
+ !x11-drivers/radeon-ucode
+ )"
+#add anything else that collides to this
+
+src_unpack() {
+ if [[ ${PV} == 99999999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ # rename directory from git snapshot tarball
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_prepare() {
+ echo "# Remove files that shall not be installed from this list." > ${PN}.conf
+ find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
+
+ if use savedconfig; then
+ restore_config ${PN}.conf
+ ebegin "Removing all files not listed in config"
+ find * \( \! -type d -and \! -name ${PN}.conf \) \
+ | sort ${PN}.conf ${PN}.conf - \
+ | uniq -u | xargs -r rm
+ eend $? || die
+ # remove empty directories, bug #396073
+ find -type d -empty -delete || die
+ fi
+}
+
+src_install() {
+ save_config ${PN}.conf
+ rm ${PN}.conf || die
+ insinto /lib/firmware/
+ doins -r *
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ ewarn "USE=savedconfig is active. You must handle file collisions manually."
+ fi
+}
+
+pkg_postinst() {
+ elog "If you are only interested in particular firmware files, edit the saved"
+ elog "configfile and remove those that you do not want."
+}
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 4ef36ee17868..df1c84ccb70f 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild,v 1.15 2012/02/29 17:37:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild,v 1.16 2012/05/03 15:57:31 chithanh Exp $
EAPI=4
inherit savedconfig
@@ -10,7 +10,7 @@ if [[ ${PV} == 99999999* ]]; then
SRC_URI=""
EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
else
- SRC_URI="mirror://gentoo/${P}.tar.gz"
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
fi
DESCRIPTION="Linux firmware files"