summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2013-01-02 19:44:10 +0000
committerMike Pagano <mpagano@gentoo.org>2013-01-02 19:44:10 +0000
commit89cb29ec2ff2ef4c77e92eb5126a5b18b94c9401 (patch)
tree94226ff3bfdbb635bfa3c43bd9e5de308df17ed4 /sys-kernel/linux-docs
parentRemove old versions. Fix header. (diff)
downloadgentoo-2-89cb29ec2ff2ef4c77e92eb5126a5b18b94c9401.tar.gz
gentoo-2-89cb29ec2ff2ef4c77e92eb5126a5b18b94c9401.tar.bz2
gentoo-2-89cb29ec2ff2ef4c77e92eb5126a5b18b94c9401.zip
Add new version
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel/linux-docs')
-rw-r--r--sys-kernel/linux-docs/ChangeLog9
-rw-r--r--sys-kernel/linux-docs/linux-docs-3.7.1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-kernel/linux-docs/ChangeLog b/sys-kernel/linux-docs/ChangeLog
index 8ec9c4029299..b49add582840 100644
--- a/sys-kernel/linux-docs/ChangeLog
+++ b/sys-kernel/linux-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/linux-docs
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.38 2012/12/08 15:50:38 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.39 2013/01/02 19:44:10 mpagano Exp $
+
+*linux-docs-3.7.1 (02 Jan 2013)
+
+ 02 Jan 2013; Michael Pagano <mpagano@gentoo.org> +linux-docs-3.7.1.ebuild:
+ Add new version
08 Dec 2012; Agostino Sarubbo <ago@gentoo.org> linux-docs-3.4.1.ebuild:
Stable for ppc64, wrt bug #429218
diff --git a/sys-kernel/linux-docs/linux-docs-3.7.1.ebuild b/sys-kernel/linux-docs/linux-docs-3.7.1.ebuild
new file mode 100644
index 000000000000..49cc48cc868d
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-3.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-3.7.1.ebuild,v 1.1 2013/01/02 19:44:10 mpagano Exp $
+
+EAPI=3
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v3.x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_prepare() {
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}