summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-07-21 22:34:05 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-07-21 22:34:05 +0000
commit665453f97aa01b70c7e993ee77b96843307bedeb (patch)
tree8321f5803ece2a2bf19fd5461eb8134db10cccfb /sys-kernel/ia64-sources
parentinherit eutils + gcc 3.4 fix (Manifest recommit) (diff)
downloadgentoo-2-665453f97aa01b70c7e993ee77b96843307bedeb.tar.gz
gentoo-2-665453f97aa01b70c7e993ee77b96843307bedeb.tar.bz2
gentoo-2-665453f97aa01b70c7e993ee77b96843307bedeb.zip
Version bump - added CAN-2004-0447 and CAN-2004-0565.
Diffstat (limited to 'sys-kernel/ia64-sources')
-rw-r--r--sys-kernel/ia64-sources/ChangeLog10
-rw-r--r--sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r7 (renamed from sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r6)0
-rw-r--r--sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0447.patch23
-rw-r--r--sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0565.patch13
-rw-r--r--sys-kernel/ia64-sources/ia64-sources-2.4.24-r7.ebuild (renamed from sys-kernel/ia64-sources/ia64-sources-2.4.24-r6.ebuild)4
5 files changed, 48 insertions, 2 deletions
diff --git a/sys-kernel/ia64-sources/ChangeLog b/sys-kernel/ia64-sources/ChangeLog
index 1600e394ef76..3e413942cee8 100644
--- a/sys-kernel/ia64-sources/ChangeLog
+++ b/sys-kernel/ia64-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/ia64-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ia64-sources/ChangeLog,v 1.19 2004/07/10 06:05:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ia64-sources/ChangeLog,v 1.20 2004/07/21 22:34:05 plasmaroo Exp $
+
+*ia64-sources-2.4.24-r7 (21 Jul 2004)
+
+ 21 Jul 2004; <plasmaroo@gentoo.org> -ia64-sources-2.4.24-r6.ebuild,
+ +ia64-sources-2.4.24-r7.ebuild,
+ +files/ia64-sources-2.4.24.CAN-2004-0447.patch,
+ +files/ia64-sources-2.4.24.CAN-2004-0565.patch:
+ Version bump - added CAN-2004-0447 and CAN-2004-0565.
09 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
ia64-sources-2.4.24-r6.ebuild:
diff --git a/sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r6 b/sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r7
index 2af043964e41..2af043964e41 100644
--- a/sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r6
+++ b/sys-kernel/ia64-sources/files/digest-ia64-sources-2.4.24-r7
diff --git a/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0447.patch b/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0447.patch
new file mode 100644
index 000000000000..d55be877c526
--- /dev/null
+++ b/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0447.patch
@@ -0,0 +1,23 @@
+--- linux-2.4.26/arch/ia64/ia32/sys_ia32.c Fri Feb 20 10:07:21 2004
++++ linux/arch/ia64/ia32/sys_ia32.c Sat Apr 17 02:13:55 2004
+@@ -111,6 +111,8 @@
+ *ap++ = (char *) A(addr);
+ arg += sizeof(unsigned int);
+ n++;
++ if (n >= (MAX_ARG_PAGES * PAGE_SIZE) / sizeof(char *))
++ return -E2BIG;
+ } while (addr);
+ return n - 1;
+ }
+diff -urPX nopatch linux-2.4.26/arch/ia64/kernel/unwind.c linux/arch/ia64/kernel/unwind.c
+--- linux-2.4.26/arch/ia64/kernel/unwind.c Sat Apr 17 02:10:25 2004
++++ linux/arch/ia64/kernel/unwind.c Sun Jun 13 10:40:37 2004
+@@ -1750,7 +1750,7 @@
+ if (!state->pri_unat_loc)
+ state->pri_unat_loc = &state->sw->ar_unat;
+ /* register off. is a multiple of 8, so the least 3 bits (type) are 0 */
+- s[dst+1] = (*state->pri_unat_loc - s[dst]) | UNW_NAT_MEMSTK;
++ s[dst+1] = ((unsigned long) state->pri_unat_loc - s[dst]) | UNW_NAT_MEMSTK;
+ break;
+
+ case UNW_INSN_SETNAT_TYPE:
diff --git a/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0565.patch b/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0565.patch
new file mode 100644
index 000000000000..94a944fa7b33
--- /dev/null
+++ b/sys-kernel/ia64-sources/files/ia64-sources-2.4.24.CAN-2004-0565.patch
@@ -0,0 +1,13 @@
+diff -uNp l1/include/asm-ia64/system.h.orig l1/include/asm-ia64/system.h
+--- l1/include/asm-ia64/system.h.orig 2004-02-18 04:57:31.000000000 +0100
++++ l1/include/asm-ia64/system.h 2004-07-01 17:01:52.185515640 +0200
+@@ -233,7 +233,8 @@ extern void ia64_load_extra (struct task
+ * the latest fph state from another CPU. In other words: eager save, lazy restore.
+ */
+ # define switch_to(prev,next,last) do { \
+- if (ia64_psr(ia64_task_regs(prev))->mfh) { \
++ if (ia64_psr(ia64_task_regs(prev))->mfh \
++ && ia64_is_local_fpu_owner(prev)) { \
+ ia64_psr(ia64_task_regs(prev))->mfh = 0; \
+ (prev)->thread.flags |= IA64_THREAD_FPH_VALID; \
+ __ia64_save_fpu((prev)->thread.fph); \
diff --git a/sys-kernel/ia64-sources/ia64-sources-2.4.24-r6.ebuild b/sys-kernel/ia64-sources/ia64-sources-2.4.24-r7.ebuild
index 1dd5e5142b74..257fdfaaef85 100644
--- a/sys-kernel/ia64-sources/ia64-sources-2.4.24-r6.ebuild
+++ b/sys-kernel/ia64-sources/ia64-sources-2.4.24-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ia64-sources/ia64-sources-2.4.24-r6.ebuild,v 1.2 2004/07/10 06:05:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ia64-sources/ia64-sources-2.4.24-r7.ebuild,v 1.1 2004/07/21 22:34:05 plasmaroo Exp $
IUSE=""
@@ -61,9 +61,11 @@ src_unpack() {
epatch ${FILESDIR}/${P}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
epatch ${FILESDIR}/${P}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
epatch ${FILESDIR}/${P}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0447.patch || die "Failed to add the CAN-2004-0447 patch!"
epatch ${FILESDIR}/${P}.CAN-2004-0495.patch || die "Failed to add the CAN-2004-0495 patch!"
epatch ${FILESDIR}/${P}.CAN-2004-0497.patch || die "Failed to add the CAN-2004-0497 patch!"
epatch ${FILESDIR}/${P}.CAN-2004-0535.patch || die "Failed to add the CAN-2004-0535 patch!"
+ epatch ${FILESDIR}/${P}.CAN-2004-0565.patch || die "Failed to add the CAN-2004-0565 patch!"
kernel_universal_unpack
}