summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-03 08:20:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-08-03 08:20:38 +0000
commit54d81c654a847a5903fba30633b11432d3ce1a37 (patch)
treeea14ebfbfc85c0754767198159330e7a5ff7e7d3 /sys-kernel/hardened-sources
parentvanilla-3.2.69 + genpatches-3.2-16 + grsecurity-3.1-3.2.69-201508020900 (diff)
downloadgentoo-2-54d81c654a847a5903fba30633b11432d3ce1a37.tar.gz
gentoo-2-54d81c654a847a5903fba30633b11432d3ce1a37.tar.bz2
gentoo-2-54d81c654a847a5903fba30633b11432d3ce1a37.zip
vanilla-3.14.48 + genpatches-3.14-53 + grsecurity-3.1-3.14.48-201508020901
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.14.48-r3.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index a17049fdb5a2..c35f61ebe468 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1329 2015/08/03 08:18:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1330 2015/08/03 08:20:38 blueness Exp $
+
+*hardened-sources-3.14.48-r3 (03 Aug 2015)
+
+ 03 Aug 2015; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.14.48-r3.ebuild:
+ vanilla-3.14.48 + genpatches-3.14-53 + grsecurity-3.1-3.14.48-201508020901
*hardened-sources-3.2.69-r13 (03 Aug 2015)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.14.48-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.14.48-r3.ebuild
new file mode 100644
index 000000000000..cb292e9661a0
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.14.48-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.14.48-r3.ebuild,v 1.1 2015/08/03 08:20:38 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="53"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}