summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-03-04 12:37:47 +0000
committerMike Pagano <mpagano@gentoo.org>2012-03-04 12:37:47 +0000
commit70f39bbc3b70e8c0083243a96eff0bb830c59b55 (patch)
tree3d79ea559850110533c0f358073117808118f104 /sys-kernel/git-sources/git-sources-3.3_rc6.ebuild
parentayatana useflag is now global (diff)
downloadgentoo-2-70f39bbc3b70e8c0083243a96eff0bb830c59b55.tar.gz
gentoo-2-70f39bbc3b70e8c0083243a96eff0bb830c59b55.tar.bz2
gentoo-2-70f39bbc3b70e8c0083243a96eff0bb830c59b55.zip
Version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/git-sources/git-sources-3.3_rc6.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-3.3_rc6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-3.3_rc6.ebuild b/sys-kernel/git-sources/git-sources-3.3_rc6.ebuild
new file mode 100644
index 000000000000..88da7aa3b547
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.3_rc6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.3_rc6.ebuild,v 1.1 2012/03/04 12:37:47 mpagano Exp $
+
+EAPI="4"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2 git-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git"
+EGIT_COMMIT="v${PV/_/-}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}