summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-10-06 01:19:54 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-10-06 01:19:54 +0000
commit4b823fdeb181132259d0cebd93fea72d38aeebc7 (patch)
treeb2596f3b9201958850456565ed0edb94ee6eaf72 /sys-kernel/gentoo-sources
parentFix missing dependency. (diff)
downloadgentoo-2-4b823fdeb181132259d0cebd93fea72d38aeebc7.tar.gz
gentoo-2-4b823fdeb181132259d0cebd93fea72d38aeebc7.tar.bz2
gentoo-2-4b823fdeb181132259d0cebd93fea72d38aeebc7.zip
Linux patches 3.0.98, 3.4.64, 3.10.14 and 3.11.4.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog12
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.0.98.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.10.14.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.11.4.ebuild29
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.4.64.ebuild29
5 files changed, 127 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 43aad3eae8a8..12b8fecd757c 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1192 2013/10/02 00:37:11 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1193 2013/10/06 01:19:54 tomwij Exp $
+
+*gentoo-sources-3.0.98 (06 Oct 2013)
+*gentoo-sources-3.11.4 (06 Oct 2013)
+*gentoo-sources-3.4.64 (06 Oct 2013)
+*gentoo-sources-3.10.14 (06 Oct 2013)
+
+ 06 Oct 2013; Tom Wijsman <TomWij@gentoo.org> +gentoo-sources-3.0.98.ebuild,
+ +gentoo-sources-3.10.14.ebuild, +gentoo-sources-3.11.4.ebuild,
+ +gentoo-sources-3.4.64.ebuild:
+ Linux patches 3.0.98, 3.4.64, 3.10.14 and 3.11.4.
*gentoo-sources-3.11.3 (02 Oct 2013)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.0.98.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.0.98.ebuild
new file mode 100644
index 000000000000..6d947e2dfe09
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.0.98.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.0.98.ebuild,v 1.1 2013/10/06 01:19:54 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="68"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.10.14.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.10.14.ebuild
new file mode 100644
index 000000000000..6606641f6034
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.10.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.10.14.ebuild,v 1.1 2013/10/06 01:19:54 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="21"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.11.4.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.11.4.ebuild
new file mode 100644
index 000000000000..b85b52159014
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.11.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.11.4.ebuild,v 1.1 2013/10/06 01:19:54 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="7"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.4.64.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.4.64.ebuild
new file mode 100644
index 000000000000..5e5498ab2b7c
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.4.64.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.4.64.ebuild,v 1.1 2013/10/06 01:19:54 tomwij Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="45"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}