summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-07-21 10:23:02 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-07-21 10:23:02 +0000
commit7dd58b349a0a29c8884b5cfabeb46152823ce9ef (patch)
tree7a1a5043f5e2e55ae63e6fe8d3f7be63f492e982 /sys-kernel/aa-sources
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-7dd58b349a0a29c8884b5cfabeb46152823ce9ef.tar.gz
gentoo-2-7dd58b349a0a29c8884b5cfabeb46152823ce9ef.tar.bz2
gentoo-2-7dd58b349a0a29c8884b5cfabeb46152823ce9ef.zip
Added a patch for the CAN-2004-0596 issue; bug #57826.
Diffstat (limited to 'sys-kernel/aa-sources')
-rw-r--r--sys-kernel/aa-sources/ChangeLog6
-rw-r--r--sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild4
-rw-r--r--sys-kernel/aa-sources/files/aa-sources-2.6.5.CAN-2004-0596.patch46
3 files changed, 53 insertions, 3 deletions
diff --git a/sys-kernel/aa-sources/ChangeLog b/sys-kernel/aa-sources/ChangeLog
index c2bcd3f84a4c..55617f33e627 100644
--- a/sys-kernel/aa-sources/ChangeLog
+++ b/sys-kernel/aa-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/aa-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.44 2004/07/09 13:56:32 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.45 2004/07/21 10:23:02 plasmaroo Exp $
+
+ 21 Jul 2004; <plasmaroo@gentoo.org> aa-sources-2.6.5-r5.ebuild,
+ +files/aa-sources-2.6.5.CAN-2004-0596.patch:
+ Added a patch for the CAN-2004-0596 issue; bug #57826.
09 Jul 2004; <plasmaroo@gentoo.org> aa-sources-2.4.23-r2.ebuild,
aa-sources-2.6.5-r5.ebuild, +files/aa-sources-2.6.5.ProcPerms.patch,
diff --git a/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild b/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
index 5b80a957d7d7..f64b756d70bf 100644
--- a/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
+++ b/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild,v 1.8 2004/07/15 03:44:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild,v 1.9 2004/07/21 10:23:02 plasmaroo Exp $
-UNIPATCH_LIST="${DISTDIR}/${KV}.bz2 ${FILESDIR}/${P}.CAN-2004-0075.patch ${FILESDIR}/${P}.CAN-2004-0228.patch ${FILESDIR}/${P}.CAN-2004-0229.patch ${FILESDIR}/${P}.CAN-2004-0427.patch ${FILESDIR}/${PN}.CAN-2004-0497.patch ${FILESDIR}/${P}.FPULockup-53804.patch ${FILESDIR}/${P}.IPTables-RDoS.patch ${FILESDIR}/${P}.ProcPerms.patch"
+UNIPATCH_LIST="${DISTDIR}/${KV}.bz2 ${FILESDIR}/${P}.CAN-2004-0075.patch ${FILESDIR}/${P}.CAN-2004-0228.patch ${FILESDIR}/${P}.CAN-2004-0229.patch ${FILESDIR}/${P}.CAN-2004-0427.patch ${FILESDIR}/${PN}.CAN-2004-0497.patch ${FILESDIR}/${P}.FPULockup-53804.patch ${FILESDIR}/${P}.IPTables-RDoS.patch ${FILESDIR}/${P}.ProcPerms.patch ${FILESDIR}/${P}.CAN-2004-0596.patch"
K_PREPATCHED="yes"
UNIPATCH_STRICTORDER="yes"
diff --git a/sys-kernel/aa-sources/files/aa-sources-2.6.5.CAN-2004-0596.patch b/sys-kernel/aa-sources/files/aa-sources-2.6.5.CAN-2004-0596.patch
new file mode 100644
index 000000000000..3e20a2e41372
--- /dev/null
+++ b/sys-kernel/aa-sources/files/aa-sources-2.6.5.CAN-2004-0596.patch
@@ -0,0 +1,46 @@
+--- 1.13/drivers/net/eql.c 2004-07-21 03:13:40 -07:00
++++ 1.14/drivers/net/eql.c 2004-07-21 03:13:40 -07:00
+@@ -495,6 +495,8 @@
+ return -EFAULT;
+
+ slave_dev = dev_get_by_name(sc.slave_name);
++ if (!slave_dev)
++ return -ENODEV;
+
+ ret = -EINVAL;
+
+@@ -527,11 +529,13 @@
+ if (copy_from_user(&sc, scp, sizeof (slave_config_t)))
+ return -EFAULT;
+
+- eql = dev->priv;
+ slave_dev = dev_get_by_name(sc.slave_name);
++ if (!slave_dev)
++ return -ENODEV;
+
+ ret = -EINVAL;
+
++ eql = dev->priv;
+ spin_lock_bh(&eql->queue.lock);
+ if (eql_is_slave(slave_dev)) {
+ slave = __eql_find_slave_dev(&eql->queue, slave_dev);
+--- 1.14/drivers/net/eql.c 2004-07-21 03:13:33 -07:00
++++ 1.15/drivers/net/eql.c 2004-07-21 03:13:33 -07:00
+@@ -499,6 +499,8 @@
+ return -ENODEV;
+
+ ret = -EINVAL;
++ if (!slave_dev)
++ return ret;
+
+ spin_lock_bh(&eql->queue.lock);
+ if (eql_is_slave(slave_dev)) {
+@@ -534,6 +536,8 @@
+ return -ENODEV;
+
+ ret = -EINVAL;
++ if (!slave_dev)
++ return ret;
+
+ eql = dev->priv;
+ spin_lock_bh(&eql->queue.lock);