summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-14 05:17:48 +0000
commitdf250d511b22c4321a4b8a2b31fce769b50b533f (patch)
tree27bf344f663fa1eb008b5b905aa232e8a0a430a7 /sys-fs
parentold (diff)
downloadgentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.gz
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.tar.bz2
gentoo-2-df250d511b22c4321a4b8a2b31fce769b50b533f.zip
old
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild124
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.36-r2.ebuild87
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.37-r1.ebuild101
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35-r11
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r21
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37-r11
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.36-sed-locale.patch51
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.37-e2p-test.patch11
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-sed-locale.patch173
9 files changed, 0 insertions, 550 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild
deleted file mode 100644
index 93aa323b86f9..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild,v 1.18 2005/08/28 06:03:14 vapier Exp $
-
-inherit eutils flag-o-matic gnuconfig toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Fix a cosmetic error in mk_cmds's help output.
- epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch ${FILESDIR}/${PN}-sed-locale.patch
- # Userpriv fix. Closes #27348
- chmod u+w po/*.po
-
- gnuconfig_update
-
- # Use -fPIC compiled shared files in .a files. Fix kdelibs-3.3.0 compilation on hppa.
- use static || sed -e '/ARUPD/s:$(OBJS):elfshared/*.o:' -i ${S}/lib/Makefile.library
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- configure e2fsck/journal.c e2fsck/recovery.c \
- e2fsck/unix.c lib/ext2fs/kernel-jbd.h \
- || die "sed jbd debug failed"
-}
-
-src_compile() {
- # building e2fsprogs on sparc results in silo breaking
- [ "${ARCH}" = "sparc" ] && filter-flags -fstack-protector
-
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- local myconf
- use static \
- && myconf="${myconf} --with-ldopts=-static" \
- || myconf="${myconf} --enable-dynamic-e2fsck --enable-elf-shlibs"
- econf \
- $(use_enable nls) \
- ${myconf} || die
-
- # Parallel make sometimes fails
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR=${D} libdir=/zapme install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /$(get_libdir) /bin /sbin
- cd ${D}/usr/$(get_libdir)
- mv * ../../$(get_libdir)
- cd ${D}/$(get_libdir)
- mv *.a ../usr/$(get_libdir)
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/$(get_libdir)
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/$(get_libdir)
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../../bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
- ln -sf mke2fs mkfs.ext3
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
- cd ${S}/$(get_libdir)/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/$(get_libdir)/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.36-r2.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.36-r2.ebuild
deleted file mode 100644
index 14e7710890aa..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.36-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.36-r2.ebuild,v 1.3 2005/08/28 06:03:14 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch "${FILESDIR}"/${P}-sed-locale.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/${P}-makefile.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # building e2fsprogs on sparc results in silo breaking
- [[ ${ARCH} == "sparc" ]] && filter-flags -fstack-protector
-
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_compile() {
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- $(use_enable nls) \
- || die
- # Parallel make sometimes fails
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # Install template awk files for compile_et
- insinto /usr/share/et
- doins "${S}"/lib/et/*.awk || die "doins et awk"
- insinto /usr/share/ss
- doins "${S}"/lib/ss/*.awk || die "doins ss awk"
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.37-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.37-r1.ebuild
deleted file mode 100644
index 2fdd5e06bddb..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.37-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.37-r1.ebuild,v 1.16 2005/08/28 06:03:14 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static"
-
-RDEPEND=">=sys-libs/com_err-${PV}
- >=sys-libs/ss-${PV}"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}; cd "${S}"
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch "${FILESDIR}"/e2fsprogs-1.36-sed-locale.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.36-makefile.patch
- # Fix tests to work #88570
- epatch "${FILESDIR}"/e2fsprogs-1.37-e2p-test.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # building e2fsprogs on sparc results in silo breaking
- [[ ${ARCH} == "sparc" ]] && filter-flags -fstack-protector
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.so lib/libcom_err.so
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
- ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
- ln -s "${ROOT}"/usr/$(get_libdir)/libss.so lib/libss.so
-
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_compile() {
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- || die
- if [[ ${CTARGET} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35-r1 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35-r1
deleted file mode 100644
index 38322e76f0f4..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8d25ffd60d405ef32d341704a2323807 e2fsprogs-1.35.tar.gz 3152299
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r2 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r2
deleted file mode 100644
index b9df1ce9da18..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1804ee96b76e5e7113fe3cecd6fe582b e2fsprogs-1.36.tar.gz 3264042
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37-r1 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37-r1
deleted file mode 100644
index f0ccfbd55831..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 084b49e919121fc0bf53c8dae23a71f8 e2fsprogs-1.37.tar.gz 3507693
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.36-sed-locale.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.36-sed-locale.patch
deleted file mode 100644
index 1ba295d6aac3..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.36-sed-locale.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -ur e2fsprogs-1.36.orig/config/config.rpath e2fsprogs-1.36/config/config.rpath
---- e2fsprogs-1.36.orig/config/config.rpath 2005-02-06 18:02:17.000000000 -0500
-+++ e2fsprogs-1.36/config/config.rpath 2005-02-06 18:04:13.000000000 -0500
-@@ -478,7 +478,7 @@
- escaped_sys_lib_search_path_spec=`echo "X$sys_lib_search_path_spec" | sed -e 's/^X//' -e "$sed_quote_subst"`
- escaped_sys_lib_dlsearch_path_spec=`echo "X$sys_lib_dlsearch_path_spec" | sed -e 's/^X//' -e "$sed_quote_subst"`
-
--sed -e 's/^\([a-zA-Z0-9_]*\)=/acl_cv_\1=/' <<EOF
-+sed -e 's/^\([[:alnum:]_]*\)=/acl_cv_\1=/' <<EOF
-
- # How to pass a linker flag through the compiler.
- wl="$escaped_wl"
-diff -ur e2fsprogs-1.36.orig/configure e2fsprogs-1.36/configure
---- e2fsprogs-1.36.orig/configure 2005-02-06 18:02:17.000000000 -0500
-+++ e2fsprogs-1.36/configure 2005-02-06 18:04:07.000000000 -0500
-@@ -1256,7 +1256,7 @@
- # value.
- ac_cache_corrupted=false
- for ac_var in `(set) 2>&1 |
-- sed -n 's/^ac_env_\([a-zA-Z_0-9]*\)_set=.*/\1/p'`; do
-+ sed -n 's/^ac_env_\([[:alnum:]_]*\)_set=.*/\1/p'`; do
- eval ac_old_set=\$ac_cv_env_${ac_var}_set
- eval ac_new_set=\$ac_env_${ac_var}_set
- eval ac_old_val="\$ac_cv_env_${ac_var}_value"
-@@ -7487,7 +7487,7 @@
- esac
- case $ac_prog in
- # Accept absolute paths.
-- [\\/]* | [A-Za-z]:[\\/]*)
-+ [\\/]* | [[:alpha:]]:[\\/]*)
- re_direlt='/[^/][^/]*/\.\./'
- # Canonicalize the path of ld
- ac_prog=`echo $ac_prog| sed 's%\\\\%/%g'`
-@@ -15068,7 +15068,7 @@
- # is no need to browse any of the substitutions).
- # These are the two extra sed commands mentioned above.
- (echo ':t
-- /@[a-zA-Z_][a-zA-Z_0-9]*@/!b' && cat $tmp/subs.frag) >$tmp/subs-$ac_sed_frag.sed
-+ /@[[:alpha:]_][[:alnum:]_]*@/!b' && cat $tmp/subs.frag) >$tmp/subs-$ac_sed_frag.sed
- if test -z "$ac_sed_cmds"; then
- ac_sed_cmds="sed -f $tmp/subs-$ac_sed_frag.sed"
- else
-@@ -15258,7 +15258,7 @@
- _ACEOF
- cat >>$CONFIG_STATUS <<\_ACEOF
- :t
--/@[a-zA-Z_][a-zA-Z_0-9]*@/!b
-+/@[[:alpha:]_][[:alnum:]_]*@/!b
- s,@configure_input@,$configure_input,;t t
- s,@srcdir@,$ac_srcdir,;t t
- s,@abs_srcdir@,$ac_abs_srcdir,;t t
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.37-e2p-test.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.37-e2p-test.patch
deleted file mode 100644
index 805f0162d53d..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.37-e2p-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- e2fsprogs-1.37.orig/lib/e2p/Makefile.in 2005-04-26 23:13:44.000000000 -0400
-+++ e2fsprogs-1.37/lib/e2p/Makefile.in 2005-04-26 23:16:49.000000000 -0400
-@@ -66,7 +66,7 @@
-
- tst_ostype: $(srcdir)/ostype.c
- @echo " LD $@"
-- @$(CC) -DTEST_PROGRAM -o tst_ostype $(srcdir)/ostype.c
-+ @$(CC) -I.. -DTEST_PROGRAM -o tst_ostype $(srcdir)/ostype.c
-
- check:: tst_ostype
- ./tst_ostype
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-sed-locale.patch b/sys-fs/e2fsprogs/files/e2fsprogs-sed-locale.patch
deleted file mode 100644
index 8a9265b95f64..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-sed-locale.patch
+++ /dev/null
@@ -1,173 +0,0 @@
-diff -urN e2fsprogs-1.34.orig/config.rpath e2fsprogs-1.34/config.rpath
---- e2fsprogs-1.34.orig/config.rpath 2003-07-23 05:57:24.000000000 -0700
-+++ e2fsprogs-1.34/config.rpath 2003-12-30 01:24:38.000000000 -0800
-@@ -478,7 +478,7 @@
- escaped_sys_lib_search_path_spec=`echo "X$sys_lib_search_path_spec" | sed -e 's/^X//' -e "$sed_quote_subst"`
- escaped_sys_lib_dlsearch_path_spec=`echo "X$sys_lib_dlsearch_path_spec" | sed -e 's/^X//' -e "$sed_quote_subst"`
-
--sed -e 's/^\([a-zA-Z0-9_]*\)=/acl_cv_\1=/' <<EOF
-+sed -e 's/^\([[:alnum:]_]*\)=/acl_cv_\1=/' <<EOF
-
- # How to pass a linker flag through the compiler.
- wl="$escaped_wl"
-diff -urN e2fsprogs-1.34.orig/configure e2fsprogs-1.34/configure
---- e2fsprogs-1.34.orig/configure 2003-07-23 06:07:31.000000000 -0700
-+++ e2fsprogs-1.34/configure 2003-12-30 01:21:32.000000000 -0800
-@@ -133,7 +133,7 @@
- fi
-
- case "$ac_option" in
-- -*=*) ac_optarg=`echo "$ac_option" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
-+ -*=*) ac_optarg=`echo "$ac_option" | sed 's/[-_[:alnum:]]*=//'` ;;
- *) ac_optarg= ;;
- esac
-
-@@ -167,7 +167,7 @@
- -disable-* | --disable-*)
- ac_feature=`echo $ac_option|sed -e 's/-*disable-//'`
- # Reject names that are not valid shell variable names.
-- if test -n "`echo $ac_feature| sed 's/[-a-zA-Z0-9_]//g'`"; then
-+ if test -n "`echo $ac_feature| sed 's/[-[:alnum:]_]//g'`"; then
- { echo "configure: error: $ac_feature: invalid feature name" 1>&2; exit 1; }
- fi
- ac_feature=`echo $ac_feature| sed 's/-/_/g'`
-@@ -176,7 +176,7 @@
- -enable-* | --enable-*)
- ac_feature=`echo $ac_option|sed -e 's/-*enable-//' -e 's/=.*//'`
- # Reject names that are not valid shell variable names.
-- if test -n "`echo $ac_feature| sed 's/[-_a-zA-Z0-9]//g'`"; then
-+ if test -n "`echo $ac_feature| sed 's/[-_[:alnum:]]//g'`"; then
- { echo "configure: error: $ac_feature: invalid feature name" 1>&2; exit 1; }
- fi
- ac_feature=`echo $ac_feature| sed 's/-/_/g'`
-@@ -407,7 +407,7 @@
- -with-* | --with-*)
- ac_package=`echo $ac_option|sed -e 's/-*with-//' -e 's/=.*//'`
- # Reject names that are not valid shell variable names.
-- if test -n "`echo $ac_package| sed 's/[-_a-zA-Z0-9]//g'`"; then
-+ if test -n "`echo $ac_package| sed 's/[-_[:alnum:]]//g'`"; then
- { echo "configure: error: $ac_package: invalid package name" 1>&2; exit 1; }
- fi
- ac_package=`echo $ac_package| sed 's/-/_/g'`
-@@ -420,7 +420,7 @@
- -without-* | --without-*)
- ac_package=`echo $ac_option|sed -e 's/-*without-//'`
- # Reject names that are not valid shell variable names.
-- if test -n "`echo $ac_package| sed 's/[-a-zA-Z0-9_]//g'`"; then
-+ if test -n "`echo $ac_package| sed 's/[-[:alnum:]_]//g'`"; then
- { echo "configure: error: $ac_package: invalid package name" 1>&2; exit 1; }
- fi
- ac_package=`echo $ac_package| sed 's/-/_/g'`
-@@ -448,7 +448,7 @@
- ;;
-
- *)
-- if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
-+ if test -n "`echo $ac_option| sed 's/[-[:lower:][:digit:].]//g'`"; then
- echo "configure: warning: $ac_option: invalid host type" 1>&2
- fi
- if test "x$nonopt" != xNONE; then
-@@ -610,7 +610,7 @@
- esac
- case $ac_prog in
- # Accept absolute paths.
-- [\\/]* | [A-Za-z]:[\\/]*)
-+ [\\/]* | [[:alpha:]]:[\\/]*)
- re_direlt='/[^/][^/]*/\.\./'
- # Canonicalize the path of ld
- ac_prog=`echo $ac_prog| sed 's%\\\\%/%g'`
-@@ -2198,7 +2198,7 @@
- #endif
- EOF
- if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
-- egrep "(^|[^a-zA-Z_0-9])off_t[^a-zA-Z_0-9]" >/dev/null 2>&1; then
-+ egrep "(^|[^[:alpha:]_[:digit:]])off_t[^[:alpha:]_[:digit:]]" >/dev/null 2>&1; then
- rm -rf conftest*
- ac_cv_type_off_t=yes
- else
-@@ -2231,7 +2231,7 @@
- #endif
- EOF
- if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
-- egrep "(^|[^a-zA-Z_0-9])size_t[^a-zA-Z_0-9]" >/dev/null 2>&1; then
-+ egrep "(^|[^[:alpha:]_[:digit:]])size_t[^[:alpha:]_[:digit:]]" >/dev/null 2>&1; then
- rm -rf conftest*
- ac_cv_type_size_t=yes
- else
-@@ -6204,11 +6204,11 @@
- # turns \\\\ into \\, and sed turns \\ into \).
- sed -n \
- -e "s/'/'\\\\''/g" \
-- -e "s/^\\([a-zA-Z0-9_]*_cv_[a-zA-Z0-9_]*\\)=\\(.*\\)/\\1=\${\\1='\\2'}/p"
-+ -e "s/^\\([[:alnum:]_]*_cv_[[:alnum:]_]*\\)=\\(.*\\)/\\1=\${\\1='\\2'}/p"
- ;;
- *)
- # `set' quotes correctly as required by POSIX, so do not add quotes.
-- sed -n -e 's/^\([a-zA-Z0-9_]*_cv_[a-zA-Z0-9_]*\)=\(.*\)/\1=${\1=\2}/p'
-+ sed -n -e 's/^\([[:alnum:]_]*_cv_[[:alnum:]_]*\)=\(.*\)/\1=${\1=\2}/p'
- ;;
- esac >> confcache
- if cmp -s $cache_file confcache; then
-@@ -6242,7 +6242,7 @@
- # Protect against shell expansion while executing Makefile rules.
- # Protect against Makefile macro expansion.
- cat > conftest.defs <<\EOF
--s%#define \([A-Za-z_][A-Za-z0-9_]*\) *\(.*\)%-D\1=\2%g
-+s%#define \([[:alpha:]_][[:alnum:]_]*\) *\(.*\)%-D\1=\2%g
- s%[ `~#$^&*(){}\\|;'"<>?]%\\&%g
- s%\[%\\&%g
- s%\]%\\&%g
-diff -urN e2fsprogs-1.34.orig/lib/ss/ct_c.sed e2fsprogs-1.34/lib/ss/ct_c.sed
---- e2fsprogs-1.34.orig/lib/ss/ct_c.sed 2002-02-02 22:03:43.000000000 -0800
-+++ e2fsprogs-1.34/lib/ss/ct_c.sed 2003-12-30 01:23:55.000000000 -0800
-@@ -44,7 +44,7 @@
- # Now we take care of some syntatic sugar.....
- #
- /^unimplemented/ {
-- s/^unimplemented [A-Za-z_0-9]*/request ss_unimplemented/
-+ s/^unimplemented [[:alpha:]_[:digit:]]*/request ss_unimplemented/
- s/;/, (dont_list, dont_summarize);/
- }
- /^unknown/ {
-@@ -93,9 +93,9 @@
- x
- b EMITHLP
- }
--s/[^a-zA-Z0-9].*//
-+s/[^[:alnum:]].*//
- x
--s/[a-zA-Z0-9]*, *//
-+s/[[:alnum:]]*, *//
- x
- :EMITHLP
- s/^/hlp: /
-@@ -114,9 +114,9 @@
- x
- b EMITREQ
- }
--s/[^A-Za-z_0-9].*//
-+s/[^[:alpha:]_[:digit:]].*//
- x
--s/[A-Za-z_0-9]*//
-+s/[[:alpha:]_[:digit:]]*//
- s/, *//
- x
- :EMITREQ
-@@ -132,14 +132,14 @@
- h
- : OPTLIST
- /^)/ b EOR
--/^[^A-Za-z_0-9]/ {
-+/^[^[:alpha:]_[:digit:]]/ {
- =
- c\
- ERROR: parse error in options list
- }
--s/[^A-Za-z_0-9].*//
-+s/[^[:alpha:]_[:digit:]].*//
- x
--s/[A-Za-z_0-9]*//
-+s/[[:alpha:]_[:digit:]]*//
- s/, *//
- x
- s/^/opt: /