summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-09 01:32:33 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-09 01:32:33 +0000
commitd7bbb0228f447feaa0ffb153659991f05c5ee2bb (patch)
tree7921259454f1486e8ef54e2cdcb687ba0eb45070 /sys-fs
parentversion bump (diff)
downloadgentoo-2-d7bbb0228f447feaa0ffb153659991f05c5ee2bb.tar.gz
gentoo-2-d7bbb0228f447feaa0ffb153659991f05c5ee2bb.tar.bz2
gentoo-2-d7bbb0228f447feaa0ffb153659991f05c5ee2bb.zip
Version bump and remove oldest revision. Update to EAPI=3, add static-libs and xz USE flags, use src_prepare and src_configure phases instead of src_compile, replace einstall with emake, and clean up src_install.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/avfs/ChangeLog10
-rw-r--r--sys-fs/avfs/avfs-0.9.9.ebuild (renamed from sys-fs/avfs/avfs-0.9.7.ebuild)45
-rw-r--r--sys-fs/avfs/metadata.xml3
3 files changed, 39 insertions, 19 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index 493d237feb1f..b08717b012db 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/avfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.21 2010/09/10 12:39:56 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.22 2010/10/09 01:32:33 radhermit Exp $
+
+*avfs-0.9.9 (09 Oct 2010)
+
+ 09 Oct 2010; Tim Harder <radhermit@gentoo.org> -avfs-0.9.7.ebuild,
+ +avfs-0.9.9.ebuild, metadata.xml:
+ Version bump and remove oldest revision. Update to EAPI=3, add static-libs
+ and xz USE flags, use src_prepare and src_configure phases instead of
+ src_compile, replace einstall with emake, and clean up src_install.
10 Sep 2010; Tobias Klausmann <klausman@gentoo.org> avfs-0.9.8-r1.ebuild:
Stable on alpha, bug #294831
diff --git a/sys-fs/avfs/avfs-0.9.7.ebuild b/sys-fs/avfs/avfs-0.9.9.ebuild
index c4d9cab52e93..17e2eee49bd6 100644
--- a/sys-fs/avfs/avfs-0.9.7.ebuild
+++ b/sys-fs/avfs/avfs-0.9.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.7.ebuild,v 1.5 2007/05/05 11:33:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.9.ebuild,v 1.1 2010/10/09 01:32:33 radhermit Exp $
-inherit linux-info
+EAPI=3
+inherit eutils linux-info
DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files."
HOMEPAGE="http://sourceforge.net/projects/avf"
@@ -10,34 +11,42 @@ SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="static-libs +xz"
-DEPEND=">=sys-fs/fuse-2.4"
+DEPEND=">=sys-fs/fuse-2.4
+ xz? ( app-arch/xz-utils )"
RDEPEND="${DEPEND}"
pkg_setup() {
kernel_is lt 2 6 && die "Must have a version 2.6 kernel. Cannot continue. :("
}
-src_compile() {
- econf --enable-fuse || die "Sorry, can't configure :("
- emake || die "Sorry make failed :("
+src_prepare() {
+ # Fixes bug #258295
+ epatch "${FILESDIR}/${PN}-0.9.8-gcc43_fix_open_missing_mode.patch"
+}
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ $(use_enable static-libs static) \
+ $(use_with xz)
}
src_install() {
- einstall || die "Sorry, make install failed :("
+ emake DESTDIR="${D}" install || die "emake install failed"
# remove cruft
- cd ${D}/usr
- rm -f bin/davpass bin/ftppass
- rm -fr include sbin ../etc
- cd ${S}
- cd doc
- dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ rm -f "${D}"/bin/davpass "${D}"/bin/ftppass || die "rm failed"
+ # install docs
+ cd "${S}"/doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse || die "dodoc failed"
cd ..
- dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO || die "dodoc failed"
docinto scripts
- dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs || die "dodoc failed"
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs || die "dosym failed"
}
pkg_postinst() {
diff --git a/sys-fs/avfs/metadata.xml b/sys-fs/avfs/metadata.xml
index 3a96ed2fd049..827722690987 100644
--- a/sys-fs/avfs/metadata.xml
+++ b/sys-fs/avfs/metadata.xml
@@ -6,4 +6,7 @@
<email>pete4abw@comcast.net</email>
<name>Peter Hyman</name>
</maintainer>
+ <use>
+ <flag name="xz">Enable LZMA/XZ archive support</flag>
+ </use>
</pkgmetadata>